summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-04 19:47:41 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-04 19:47:41 +0000
commit4bbeb74b2ed064a99fe74b486241a32d1e53b6a1 (patch)
tree73d375ad6cffa21e97657d187b3053004b1c3414 /package/Makefile.in
parent842686b9fbfebcc2aa3a66967753c1c0855f58e7 (diff)
- the $(XSERVER) target can be provided by different X server impls. Adjust users
- rdesktop needs an xserver impl
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index f8557f700..531f8de1f 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -111,3 +111,16 @@ ifeq ($(BR2_INSTALL_LIBSTDCPP),)
TARGET_CONFIGURE_OPTS+=CXX=""
endif
+# X Windowing system
+
+XSERVER:=
+ifeq ($(strip $(BR2_PACKAGE_TINYX)),y)
+XSERVER+=tinyx
+endif
+ifeq ($(strip $(BR2_PACKAGE_XORG)),y)
+XSERVER+=xorg
+endif
+ifeq ($(strip $(BR2_PACKAGE_XGGI)),y)
+XSERVER+=xggi
+endif
+