summaryrefslogtreecommitdiff
path: root/package/autoconf
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/autoconf
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/autoconf')
-rw-r--r--package/autoconf/Makefile.in3
-rw-r--r--package/autoconf/autoconf.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/autoconf/Makefile.in b/package/autoconf/Makefile.in
deleted file mode 100644
index 30dbd840a..000000000
--- a/package/autoconf/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_AUTOCONF)),y)
-TARGETS+=autoconf
-endif
diff --git a/package/autoconf/autoconf.mk b/package/autoconf/autoconf.mk
index ff9251085..ce1ba315e 100644
--- a/package/autoconf/autoconf.mk
+++ b/package/autoconf/autoconf.mk
@@ -70,3 +70,11 @@ autoconf-clean:
autoconf-dirclean:
rm -rf $(AUTOCONF_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_AUTOCONF)),y)
+TARGETS+=autoconf
+endif