summaryrefslogtreecommitdiff
path: root/package/automake/automake.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-08-09 00:46:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-13 16:13:37 +0100
commit61f677cb060732316b41f072210986e97ae9379f (patch)
tree62883025a99039dc167db14f3b062c50529fe3bc /package/automake/automake.mk
parentf0bdacdb5b8fe0fbc276ed510fc58e9a219f5cf8 (diff)
gtk-doc: add gtk-doc.m4 to satisfy aclocal
When packages using gtk-doc are autoreconfigured, aclocal complains because it cannot find the macros defined in gtk-doc.m4. We could compile the gtk-doc package for the host, but it depends on gnome-doc-utils, which depends on libxml2, libxslt, and other packages as well. Since we don't care about the documentation, all is needed is in fact the gtk-doc.m4, so that the configure script can be generated, and we can use the --disable-gtk-doc to not generate the documentation. To solve this, we include a gtk-doc.m4 file in package/automake/, and it gets installed in $(STAGING_DIR)/usr/share/aclocal/ during the installation of the host automake (used for autoreconfiguration of packages). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/automake/automake.mk')
-rw-r--r--package/automake/automake.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/automake/automake.mk b/package/automake/automake.mk
index 65db386c5..eb3b3755e 100644
--- a/package/automake/automake.mk
+++ b/package/automake/automake.mk
@@ -15,6 +15,12 @@ AUTOMAKE_DEPENDENCIES = autoconf microperl
HOST_AUTOMAKE_DEPENDENCIES = host-autoconf
+define GTK_DOC_M4_INSTALL
+ $(INSTALL) -m 0644 package/automake/gtk-doc.m4 $(STAGING_DIR)/usr/share/aclocal/
+endef
+
+HOST_AUTOMAKE_POST_INSTALL_HOOKS += GTK_DOC_M4_INSTALL
+
$(eval $(call AUTOTARGETS,package,automake))
$(eval $(call AUTOTARGETS,package,automake,host))