summaryrefslogtreecommitdiff
path: root/package/bash/bash.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-12-27 21:46:32 +0000
committerEric Andersen <andersen@codepoet.org>2004-12-27 21:46:32 +0000
commit3d7a187f7690d3d42f59f933f5d4aa32c096b7b4 (patch)
treeee8cd2d79f6a33ed283a18fd9b79cc64855d91f8 /package/bash/bash.mk
parentc0ca7f4bdcfd5be65adf696be5c55767f64b1875 (diff)
If both bash and busybox are selected, make certain bash wins
the fight over who gets to own the /bin/sh symlink -Erik
Diffstat (limited to 'package/bash/bash.mk')
-rw-r--r--package/bash/bash.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index 704b45b73..64f40d7be 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -63,7 +63,13 @@ $(TARGET_DIR)/$(BASH_TARGET_BINARY): $(BASH_DIR)/$(BASH_BINARY)
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+#If both bash and busybox are selected, make certain bash wins
+#the fight over who gets to own the /bin/sh symlink
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+bash: ncurses uclibc busybox $(TARGET_DIR)/$(BASH_TARGET_BINARY)
+else
bash: ncurses uclibc $(TARGET_DIR)/$(BASH_TARGET_BINARY)
+endif
bash-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BASH_DIR) uninstall