summaryrefslogtreecommitdiff
path: root/package/bind/bind.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-04-14 19:25:54 +0000
committerEric Andersen <andersen@codepoet.org>2006-04-14 19:25:54 +0000
commitcb7b678a5e9ad4e452903e11649889e0b97a91ce (patch)
treeb6f89b66f9fd7a73294ade768546a4d19d588365 /package/bind/bind.mk
parent55d713a4ecb8ecdfc929f8cd83e73c1973a56f78 (diff)
664: bind package update: akvadrako writes:
This patch consists of: (1) bind version bump (2) removing some X-compiling build fixes merged upstream (3) removing the bind-dlopen patch: not of general enough use (4) remove the package/bind/bind9 file - it isn't used (5) Use $(STAGING_DIR)/lib instead of $(STAGING_DIR)/usr/lib (6) Fix chroot'ed bind handling by init script
Diffstat (limited to 'package/bind/bind.mk')
-rw-r--r--package/bind/bind.mk15
1 files changed, 7 insertions, 8 deletions
diff --git a/package/bind/bind.mk b/package/bind/bind.mk
index c321cabec..8872da77e 100644
--- a/package/bind/bind.mk
+++ b/package/bind/bind.mk
@@ -3,7 +3,7 @@
# bind
#
#############################################################
-BIND_VER:=9.3.1
+BIND_VER:=9.3.2
BIND_SOURCE:=bind-$(BIND_VER).tar.gz
BIND_SITE:=ftp://ftp.isc.org/isc/bind9/$(BIND_VER)
BIND_DIR1:=$(TOOL_BUILD_DIR)/bind-$(BIND_VER)
@@ -44,8 +44,8 @@ $(BIND_DIR2)/Makefile: $(BIND_DIR2)/.unpacked
--without-openssl \
--with-randomdev=/dev/random \
--enable-ipv6 \
- --disable-static \
--with-libtool \
+ --with-pic \
);
$(BIND_DIR2)/$(BIND_BINARY): $(BIND_DIR2)/Makefile
@@ -73,18 +73,17 @@ bind-bin: $(TARGET_DIR)/$(BIND_TARGET_BINARY) bind-lib
$(STAGING_DIR)/lib/libdns.so: $(BIND_DIR2)/$(BIND_BINARY)
$(MAKE) $(TARGET_CONFIGURE_OPTS) -j1 DESTDIR=$(STAGING_DIR) -C $(BIND_DIR2)/lib install
-$(TARGET_DIR)/usr/lib/libdns.so: $(STAGING_DIR)/lib/libdns.so
- mkdir -p $(TARGET_DIR)/usr/lib
+$(TARGET_DIR)/lib/libdns.so: $(STAGING_DIR)/lib/libdns.so
+ mkdir -p $(TARGET_DIR)/lib
cd $(STAGING_DIR)/lib; \
- cp -a libdns.* libisc.* libisccc.* libbind9.* liblwres.* libisccfg.* \
- $(TARGET_DIR)/usr/lib
+ cp -a libdns*so* libisc*so* libbind9*so* \
+ liblwres*so* $(TARGET_DIR)/lib
-bind-lib: $(STAGING_DIR)/lib/libdns.so $(TARGET_DIR)/usr/lib/libdns.so
+bind-lib: $(STAGING_DIR)/lib/libdns.so $(TARGET_DIR)/lib/libdns.so
bind: uclibc bind-bin bind-lib
bind-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BIND_DIR2) uninstall
-$(MAKE) -C $(BIND_DIR2) clean
bind-dirclean: