summaryrefslogtreecommitdiff
path: root/package/boost
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2012-04-16 15:06:55 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-16 22:33:08 +0200
commit5d8af3747afb10094886e282f416fb0221cb1350 (patch)
treefd9d55672e118b270f6cd15e4a2e0dca25c722cf /package/boost
parent39c8e4d80cc31c1d7391dfeaa6926531fab9e01f (diff)
boost: pass -dumpversion to user-config.jam
Short version avoids compiling problems with toolchains containing long version string like Linaro toolchain. [Peter: drop head/sed as -dumpversion returns version directly] Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/boost')
-rw-r--r--package/boost/boost.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 8b8a3cfe5..9da427af5 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -10,7 +10,7 @@ BOOST_SOURCE = boost_$(BOOST_FILE_VERSION).tar.bz2
BOOST_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/boost
BOOST_INSTALL_STAGING = YES
-TARGET_CC_VERSION = $(shell $(TARGET_CC) --version | head -n 1 | sed -e "s/.*[[:space:]]\([[:digit:].]\+$$\)/\1/g" )
+TARGET_CC_VERSION = $(shell $(TARGET_CC) -dumpversion)
BOOST_DEPENDENCIES = bzip2 zlib