summaryrefslogtreecommitdiff
path: root/package/busybox/busybox.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-11-21 14:36:48 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-11-21 14:36:48 +0000
commit82569c48fe40088fbb8ae08a962c82aaa904ea05 (patch)
tree5fc77e722710ea33c867d9a056fcfb41e52b5afb /package/busybox/busybox.mk
parent5d66e99e6cf1a2393de17e1d5a9753c3c1f0f621 (diff)
busybox: fixup id applet on 1.13.0 for old uclibc versions
The id applet in 1.13.0 only compiles with uclibc < 0.9.30 if the busybox internal passwd/grp functions are used. Therefore, automatically enable CONFIG_USE_BB_PWD_GRP if that situation is detected and warn the user.
Diffstat (limited to 'package/busybox/busybox.mk')
-rw-r--r--package/busybox/busybox.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 969502bf8..dd120a881 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -60,6 +60,14 @@ ifeq ($(BR2_BUSYBOX_VERSION_1_2_2_1),y)
$(SED) s,^PREFIX=.*,CROSS_COMPILER_PREFIX=\"$(TARGET_CROSS)\", \
$(BUSYBOX_DIR)/.config
endif
+# id applet breaks on 1.13.0 with old uclibc unless the bb pwd routines are used
+ifeq ($(BR2_BUSYBOX_VERSION_1_13_X)$(BR2_UCLIBC_VERSION_0_9_28_3)$(BR2_UCLIBC_VERSION_0_9_29),yy)
+ if grep -q 'CONFIG_ID=y' $(BUSYBOX_DIR)/.config; \
+ then \
+ echo 'warning: CONFIG_ID needs BB_PWD_GRP with old uclibc, enabling' >&2;\
+ $(SED) "s/^.*CONFIG_USE_BB_PWD_GRP.*/CONFIG_USE_BB_PWD_GRP=y/;" $(BUSYBOX_DIR)/.config; \
+ fi
+endif
ifeq ($(BR2_PACKAGE_BUSYBOX_SNAPSHOT),y)
$(SED) s,^CROSS_COMPILER_PREFIX=.*,CROSS_COMPILER_PREFIX=\"$(TARGET_CROSS)\", \
$(BUSYBOX_DIR)/.config