summaryrefslogtreecommitdiff
path: root/package/cloop/cloop.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-16 10:47:34 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-28 20:13:05 +0100
commit467f221d20f2a1927ef695bd4ac92559257ce8f9 (patch)
treeb35ba2b00b5dc4a3252868e7376651dfe2a86711 /package/cloop/cloop.mk
parent6527001c9d42b95c76b7689ed8eeecd8d17740cd (diff)
cloop: bump and fix package
On a machine without zlib-dev installed, cloop must rely on the host-zlib compiled by Buildroot, but due to the horrible cloop build system, this didn't happen and the build was failing. Therefore, we now pass all the $(HOST_CONFIGURE_OPTS) when building cloop, and we fix the Makefile so that it takes into account CFLAGS/LDFLAGS passed in the environment or command-line and do not override them. [Peter: fix typos, remove HOST_MAKE_ENV] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/cloop/cloop.mk')
-rw-r--r--package/cloop/cloop.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/cloop/cloop.mk b/package/cloop/cloop.mk
index 4c160986c..fa47a5f5f 100644
--- a/package/cloop/cloop.mk
+++ b/package/cloop/cloop.mk
@@ -1,12 +1,11 @@
-CLOOP_VERSION=2.631-1
+CLOOP_VERSION=2.634-1
CLOOP_SOURCE=cloop_$(CLOOP_VERSION).tar.gz
CLOOP_SITE=http://debian-knoppix.alioth.debian.org/packages/sources/cloop
HOST_CLOOP_DEPENDENCIES = host-zlib
define HOST_CLOOP_BUILD_CMDS
- $(HOST_MAKE_ENV) $(MAKE1) \
- CFLAGS="$(HOST_CFLAGS) -Wall -O2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_ERROR_SILENT" -C $(@D) APPSONLY=yes
+ $(HOST_CONFIGURE_OPTS) $(MAKE1) -C $(@D) APPSONLY=yes
endef
define HOST_CLOOP_INSTALL_CMDS