summaryrefslogtreecommitdiff
path: root/package/config
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-27 12:37:30 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-27 12:37:30 +0000
commit153b1beaeb02e1d4780428c0387b7003644e402b (patch)
treebcccc4c78a3003a3c008555e355d7ad891e3e448 /package/config
parent0c238e669f338d374e3140d77cb770301c45a978 (diff)
- fix building mconf with curses flags
- make sure to rm .config when the first 'make menuconfig' was interrupted and thus no .config.cmd was created.
Diffstat (limited to 'package/config')
-rw-r--r--package/config/Makefile2
-rw-r--r--package/config/Makefile.kconfig3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/config/Makefile b/package/config/Makefile
index 3b4384920..f25b704e6 100644
--- a/package/config/Makefile
+++ b/package/config/Makefile
@@ -5,7 +5,7 @@ top_builddir=../../
srctree := .
include Makefile.kconfig
-HOSTCFLAGS+=-Dinline="" -include foo.h
+#HOSTCFLAGS+=-Dinline="" -include foo.h
-include .depend
.depend: $(wildcard *.h *.c)
$(HOSTCC) $(HOST_EXTRACFLAGS) $(HOSTCFLAGS) -MM *.c > .depend 2>/dev/null || :
diff --git a/package/config/Makefile.kconfig b/package/config/Makefile.kconfig
index 7e7e14787..016397f66 100644
--- a/package/config/Makefile.kconfig
+++ b/package/config/Makefile.kconfig
@@ -120,6 +120,9 @@ hostprogs-y := conf qconf gconf kxgettext
ifeq ($(MAKECMDGOALS),menuconfig)
hostprogs-y += mconf
endif
+ifeq ($(findstring mconf,$(MAKECMDGOALS)),mconf)
+ hostprogs-y += mconf
+endif
ifeq ($(MAKECMDGOALS),xconfig)
qconf-target := 1