summaryrefslogtreecommitdiff
path: root/package/config
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-21 17:21:40 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 12:26:56 +0200
commit8b6585a9d3adf35179c988a10edd16ffc2c15346 (patch)
tree4f3e824fb1d7600b88bab15dfd690970f95a0686 /package/config
parent52a142a6314905422f14f05fccafdce35bea7f08 (diff)
Add support for the new nconf configuration tool
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/config')
-rw-r--r--package/config/Makefile3
-rw-r--r--package/config/patches/06-br-build-system-integration.patch19
2 files changed, 16 insertions, 6 deletions
diff --git a/package/config/Makefile b/package/config/Makefile
index 7e199bc9d..d8d44b042 100644
--- a/package/config/Makefile
+++ b/package/config/Makefile
@@ -177,6 +177,9 @@ hostprogs-y := conf qconf gconf kxgettext
ifeq ($(MAKECMDGOALS),nconfig)
hostprogs-y += nconf
endif
+ifeq ($(findstring nconf,$(MAKECMDGOALS)),nconf)
+ hostprogs-y += nconf
+endif
ifeq ($(MAKECMDGOALS),menuconfig)
hostprogs-y += mconf
diff --git a/package/config/patches/06-br-build-system-integration.patch b/package/config/patches/06-br-build-system-integration.patch
index a2e634ffd..128bbc02c 100644
--- a/package/config/patches/06-br-build-system-integration.patch
+++ b/package/config/patches/06-br-build-system-integration.patch
@@ -1,12 +1,19 @@
---
- Makefile | 11 ++++++++++-
- 1 file changed, 10 insertions(+), 1 deletion(-)
+ Makefile | 14 +++++++++++++-
+ 1 file changed, 13 insertions(+), 1 deletion(-)
-Index: config.new/Makefile
+Index: config/Makefile
===================================================================
---- config.new.orig/Makefile
-+++ config.new/Makefile
-@@ -181,14 +181,23 @@
+--- config.orig/Makefile
++++ config/Makefile
+@@ -177,18 +177,30 @@
+ ifeq ($(MAKECMDGOALS),nconfig)
+ hostprogs-y += nconf
+ endif
++ifeq ($(findstring nconf,$(MAKECMDGOALS)),nconf)
++ hostprogs-y += nconf
++endif
+
ifeq ($(MAKECMDGOALS),menuconfig)
hostprogs-y += mconf
endif