summaryrefslogtreecommitdiff
path: root/package/config
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-01 09:03:36 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-01 09:03:36 +0200
commit8e29430410f37fe152c374d1c103a32f1906740e (patch)
tree2c4f25352734350835367abbdbda7ef79598c3f6 /package/config
parentcf4689f8b1f8e2b3cc44b3395add5f0df4f3bd55 (diff)
Makefile: fixup make distclean after kconfig build in BUILD_DIR
We don't actually need to explicitly clean the kconfig stuff, as distclean already removes the entire BUILD_DIR, but fix up the packag/config makefile to do the right thing if make clean/distclean is called manually for completeness. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/config')
-rw-r--r--package/config/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/config/Makefile b/package/config/Makefile
index f0a030f80..2b266b872 100644
--- a/package/config/Makefile
+++ b/package/config/Makefile
@@ -2,6 +2,7 @@ src := .
top_srcdir=../../
top_builddir=../../
srctree := .
+obj ?= .
include Makefile.kconfig
#HOSTCFLAGS+=-Dinline="" -include foo.h
@@ -42,11 +43,11 @@ $(obj)/%:: $(src)/%_shipped
$(Q)cat $< > $@
clean:
- $(Q)rm -f $(clean-files)
+ $(Q)rm -f $(addprefix $(obj)/,$(clean-files))
distclean: clean
- $(Q)rm -f $(lxdialog) $(conf-objs) $(mconf-objs) $(kxgettext-objs) \
+ $(Q)rm -f $(addprefix $(obj)/,$(lxdialog) $(conf-objs) $(mconf-objs) $(kxgettext-objs) \
$(hostprogs-y) $(qconf-cxxobjs) $(qconf-objs) $(gconf-objs) \
- mconf .depend
+ mconf .depend)
FORCE:
.PHONY: FORCE clean distclean