summaryrefslogtreecommitdiff
path: root/package/coreutils
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-12-27 21:49:53 +0000
committerEric Andersen <andersen@codepoet.org>2004-12-27 21:49:53 +0000
commitb5a211c68eb8f6a5c00910eb96c5339c37df65ab (patch)
tree7f13e7b73ffcf8604c9ef817fe0b59e2204d8ee8 /package/coreutils
parent3d7a187f7690d3d42f59f933f5d4aa32c096b7b4 (diff)
When both busybox and coreutils and/or util-linux are selected,
make certain that it is coreutils and/or util-linux that actually gets their utilities installed. -Erik
Diffstat (limited to 'package/coreutils')
-rw-r--r--package/coreutils/coreutils.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index caad648a8..df07a0885 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -73,7 +73,13 @@ $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY): $(COREUTILS_DIR)/$(COREUTILS_BINARY)
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+#If both coreutils and busybox are selected, make certain coreutils
+#wins the fight over who gets to have their utils actually installed
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+coreutils: uclibc busybox $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
+else
coreutils: uclibc $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
+endif
coreutils-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(COREUTILS_DIR) uninstall