summaryrefslogtreecommitdiff
path: root/package/database/sqlite
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-04-26 21:57:11 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-04-26 21:57:11 +0200
commit187f0a55323437e33f5a66ef670fe0e49f52bc45 (patch)
treec90a6c5afa2ae97c6c73d2e8ae0e64c195407665 /package/database/sqlite
parent28200ca3f233480de4179e58099ba5c9f335087c (diff)
package: get rid of database subdir
Not much point in a seperate subdir for only two packages. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/database/sqlite')
-rw-r--r--package/database/sqlite/Config.in16
-rw-r--r--package/database/sqlite/sqlite.mk49
2 files changed, 0 insertions, 65 deletions
diff --git a/package/database/sqlite/Config.in b/package/database/sqlite/Config.in
deleted file mode 100644
index f9b12ae9f..000000000
--- a/package/database/sqlite/Config.in
+++ /dev/null
@@ -1,16 +0,0 @@
-config BR2_PACKAGE_SQLITE
- bool "sqlite"
- help
- SQLite is a small C library that implements a self-contained,
- embeddable, zero-configuration SQL database engine.
-
- http://www.sqlite.org/
-
-config BR2_PACKAGE_SQLITE_READLINE
- bool "Command-line editing"
- depends on BR2_PACKAGE_SQLITE
- select BR2_PACKAGE_NCURSES
- select BR2_PACKAGE_READLINE
- help
- Enable command-line editing. This requires ncurses and readline.
-
diff --git a/package/database/sqlite/sqlite.mk b/package/database/sqlite/sqlite.mk
deleted file mode 100644
index 375ab42ef..000000000
--- a/package/database/sqlite/sqlite.mk
+++ /dev/null
@@ -1,49 +0,0 @@
-#############################################################
-#
-# sqlite
-#
-#############################################################
-
-SQLITE_VERSION = 3.6.22
-SQLITE_SOURCE = sqlite-amalgamation-$(SQLITE_VERSION).tar.gz
-SQLITE_SITE = http://www.sqlite.org
-SQLITE_INSTALL_STAGING = YES
-SQLITE_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
-SQLITE_LIBTOOL_PATCH = NO
-
-ifneq ($(BR2_LARGEFILE),y)
-# the sqlite configure script fails to define SQLITE_DISABLE_LFS when
-# --disable-largefile is passed, breaking the build. Work around it by
-# simply adding it to CFLAGS for configure instead
-SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DSQLITE_DISABLE_LFS"
-# changing CFLAGS doesn't work with config.cache
-SQLITE_USE_CONFIG_CACHE = NO
-endif
-
-SQLITE_CONF_OPT = --enable-shared \
- --enable-static \
- --enable-tempstore=yes \
- --enable-threadsafe \
- --enable-releasemode \
- --disable-tcl \
- --localstatedir=/var
-
-ifeq ($(BR2_PACKAGE_SQLITE_READLINE),y)
-SQLITE_DEPENDENCIES += ncurses readline
-SQLITE_CONF_OPT += --with-readline-inc="-I$(STAGING_DIR)/usr/include"
-else
-SQLITE_CONF_OPT += --disable-readline
-endif
-
-$(eval $(call AUTOTARGETS,package,sqlite))
-
-$(SQLITE_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
- rm -f $(TARGET_DIR)/usr/bin/sqlite3
- rm -f $(TARGET_DIR)/usr/lib/libsqlite3*
- rm -f $(STAGING_DIR)/usr/bin/sqlite3
- rm -f $(STAGING_DIR)/usr/lib/libsqlite3*
- rm -f $(STAGING_DIR)/usr/lib/pkgconfig/sqlite3.pc
- rm -f $(STAGING_DIR)/usr/include/sqlite3*.h
- rm -f $(SQLITE_TARGET_INSTALL_TARGET) $(SQLITE_HOOK_POST_INSTALL)
-