summaryrefslogtreecommitdiff
path: root/package/dbus
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-31 21:01:24 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-31 21:01:24 +0000
commitf777dee1d4688a509481ddc16d00d4bf4faca11b (patch)
treecaccc284f6d7df982e8d6e89146554e1893751f1 /package/dbus
parent59f084017e1d72471dcf4af4122b743cf60cbccb (diff)
Unbreak Peters 'fixes' to dbus for a second time
Diffstat (limited to 'package/dbus')
-rw-r--r--package/dbus/dbus.mk16
1 files changed, 5 insertions, 11 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index 92405bd5b..e0522411b 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -13,18 +13,10 @@ DBUS_TARGET_BINARY:=usr/bin/dbus-daemon
ifeq ($(BR2_DBUS_EXPAT),y)
DBUS_XML:=expat
-# depend on the exact library file instead of expat so dbus isn't always
-# considered out-of-date
-DBUS_XML_DEP:=$(STAGING_DIR)/usr/lib/libexpat.so.1
+DBUS_XML_DEP:=expat
else
DBUS_XML:=libxml
-# Makefile.autotools.in unfortunately has broken dependency handling,
-# so we cannot do the same for libxml2 as the targets (like
-# libxml2-install-staging) are phony and hence, dbus will always be
-# considered out-of-date. Using the corresponding .stamp_* files (E.G.
-# LIBXML2_TARGET_INSTALL_STAGING doesn't work as there's no dependency
-# information between them.
-DBUS_XML_DEP:=libxml2-install-staging
+DBUS_XML_DEP:=libxml2
endif
$(DL_DIR)/$(DBUS_SOURCE):
@@ -94,7 +86,7 @@ ifneq ($(BR2_HAVE_MANPAGES),y)
rm -rf $(TARGET_DIR)/usr/share/man
endif
-dbus: uclibc pkgconfig $(TARGET_DIR)/$(DBUS_TARGET_BINARY)
+dbus: uclibc pkgconfig $(DBUS_XML_DEP) $(TARGET_DIR)/$(DBUS_TARGET_BINARY)
dbus-clean:
rm -f $(TARGET_DIR)/etc/dbus-1/session.conf
@@ -121,3 +113,5 @@ dbus-dirclean:
ifeq ($(BR2_PACKAGE_DBUS),y)
TARGETS+=dbus
endif
+
+