summaryrefslogtreecommitdiff
path: root/package/dm
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/dm
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/dm')
-rw-r--r--package/dm/dm.mk15
1 files changed, 13 insertions, 2 deletions
diff --git a/package/dm/dm.mk b/package/dm/dm.mk
index 33830a7bd..cf88ccd74 100644
--- a/package/dm/dm.mk
+++ b/package/dm/dm.mk
@@ -62,6 +62,17 @@ $(DM_DIR)/.configured: $(DM_DIR)/.unpacked
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
$(DISABLE_NLS) \
$(DISABLE_LARGEFILE) \
--with-user=$(shell id -un) --with-group=$(shell id -gn) \
@@ -72,8 +83,8 @@ $(DM_DIR)/$(DM_BINARY): dm-build
$(DM_DIR)/$(DM_LIBRARY): dm-build
$(DM_STAGING_BINARY) $(DM_STAGING_LIBRARY): $(DM_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) DESTDIR=$(STAGING_DIR) -C $(DM_DIR)
- $(MAKE) -C $(DM_DIR) install prefix=$(STAGING_DIR)
+ $(MAKE) CC=$(TARGET_CC) -C $(DM_DIR)
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(DM_DIR) install
# Install dmsetup from staging to target
$(DM_TARGET_BINARY): $(DM_STAGING_BINARY)