summaryrefslogtreecommitdiff
path: root/package/dmidecode/dmidecode-build-system-fixes.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-06-02 06:13:57 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-06-11 22:43:59 +0200
commit9d3547529b87ce3bddfcdc962e0c9d6d2b2ed9d5 (patch)
tree65e0d8c14cbbd9c0ce34766b13464da3dd9fc60e /package/dmidecode/dmidecode-build-system-fixes.patch
parent83f43bab374535fe39d93547fb03c52fa45ab0a8 (diff)
dmidecode: new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dmidecode/dmidecode-build-system-fixes.patch')
-rw-r--r--package/dmidecode/dmidecode-build-system-fixes.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/package/dmidecode/dmidecode-build-system-fixes.patch b/package/dmidecode/dmidecode-build-system-fixes.patch
new file mode 100644
index 000000000..275f9df7f
--- /dev/null
+++ b/package/dmidecode/dmidecode-build-system-fixes.patch
@@ -0,0 +1,35 @@
+Minor build system fixes
+
+Usual build system fixes to allow CC/CFLAGS/LDFLAGS to be overriden
+from the command line, and completed by additional flags from the
+Makefile.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -12,9 +12,10 @@
+ # (at your option) any later version.
+ #
+
+-CC = gcc
+-CFLAGS = -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+- -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
++CC ?= gcc
++override CFLAGS += \
++ -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
++ -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
+ #CFLAGS += -DBIGENDIAN
+ #CFLAGS += -DALIGNMENT_WORKAROUND
+
+@@ -23,7 +24,7 @@
+ #CFLAGS += -g
+
+ # Pass linker flags here
+-LDFLAGS =
++override LDFLAGS +=
+
+ DESTDIR =
+ prefix = /usr/local