summaryrefslogtreecommitdiff
path: root/package/expat
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/expat
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/expat')
-rw-r--r--package/expat/expat.mk14
-rw-r--r--package/expat/libdir-la.patch77
2 files changed, 85 insertions, 6 deletions
diff --git a/package/expat/expat.mk b/package/expat/expat.mk
index d14d3674f..82708978c 100644
--- a/package/expat/expat.mk
+++ b/package/expat/expat.mk
@@ -29,13 +29,15 @@ $(EXPAT_DIR)/.configured: $(EXPAT_DIR)/.unpacked
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
- --bindir=$(STAGING_DIR)/usr/bin \
- --sbindir=$(STAGING_DIR)/usr/sbin \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
- --mandir=$(STAGING_DIR)/man \
+ --includedir=/include \
+ --mandir=/usr/man \
--infodir=/usr/info \
--enable-shared \
);
@@ -46,8 +48,8 @@ $(EXPAT_DIR)/.libs/libexpat.a: $(EXPAT_DIR)/.configured
touch -c $(EXPAT_DIR)/.libs/libexpat.a
$(STAGING_DIR)/lib/libexpat.so.1: $(EXPAT_DIR)/.libs/libexpat.a
- $(MAKE) -C $(EXPAT_DIR) prefix=$(STAGING_DIR) \
- exec_prefix=$(STAGING_DIR) mandir=$(STAGING_DIR)/man install
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(EXPAT_DIR) install
+ $(SED) "s,^libdir=.*,libdir=\'$(STAGING_DIR)/lib\',g" $(STAGING_DIR)/lib/libexpat.la
touch -c $(STAGING_DIR)/lib/libexpat.so.1
$(TARGET_DIR)/lib/libexpat.so.1: $(STAGING_DIR)/lib/libexpat.so.1
@@ -56,7 +58,7 @@ $(TARGET_DIR)/lib/libexpat.so.1: $(STAGING_DIR)/lib/libexpat.so.1
-$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libexpat.so.0.5.0
touch -c $(TARGET_DIR)/lib/libexpat.so.1
-expat: uclibc $(TARGET_DIR)/lib/libexpat.so.1
+expat: uclibc pkgconfig $(TARGET_DIR)/lib/libexpat.so.1
expat-clean:
rm -f $(EXPAT_DIR)/.configured
diff --git a/package/expat/libdir-la.patch b/package/expat/libdir-la.patch
new file mode 100644
index 000000000..1c8930ea6
--- /dev/null
+++ b/package/expat/libdir-la.patch
@@ -0,0 +1,77 @@
+--- expat-2.0.0/conftools/ltmain.sh.orig 2007-01-13 14:39:51.000000000 -0700
++++ expat-2.0.0/conftools/ltmain.sh 2007-01-13 14:39:56.000000000 -0700
+@@ -273,8 +273,9 @@
+ # line option must be used.
+ if test -z "$tagname"; then
+ $echo "$modename: unable to infer tagged configuration"
+- $echo "$modename: specify a tag with \`--tag'" 1>&2
+- exit $EXIT_FAILURE
++ $echo "$modename: defaulting to \`CC'"
++ $echo "$modename: if this is not correct, specify a tag with \`--tag'"
++# exit $EXIT_FAILURE
+ # else
+ # $echo "$modename: using $tagname tagged configuration"
+ fi
+@@ -2404,8 +2405,14 @@
+ absdir="$abs_ladir"
+ libdir="$abs_ladir"
+ else
+- dir="$libdir"
+- absdir="$libdir"
++ # Adding 'libdir' from the .la file to our library search paths
++ # breaks crosscompilation horribly. We cheat here and don't add
++ # it, instead adding the path where we found the .la. -CL
++ dir="$abs_ladir"
++ absdir="$abs_ladir"
++ libdir="$abs_ladir"
++ #dir="$libdir"
++ #absdir="$libdir"
+ fi
+ test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes
+ else
+@@ -2886,6 +2893,16 @@
+ esac
+ if grep "^installed=no" $deplib > /dev/null; then
+ path="$absdir/$objdir"
++# This interferes with crosscompilation. -CL
++# else
++# eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
++# if test -z "$libdir"; then
++# $echo "$modename: \`$deplib' is not a valid libtool archive" 1>&2
++# exit 1
++# fi
++# if test "$absdir" != "$libdir"; then
++# $echo "$modename: warning: \`$deplib' seems to be moved" 1>&2
++# fi
+ else
+ eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
+ if test -z "$libdir"; then
+@@ -5598,6 +5615,10 @@
+ # Replace all uninstalled libtool libraries with the installed ones
+ newdependency_libs=
+ for deplib in $dependency_libs; do
++ # Replacing uninstalled with installed can easily break crosscompilation,
++ # since the installed path is generally the wrong architecture. -CL
++ newdependency_libs="$newdependency_libs $deplib"
++ continue
+ case $deplib in
+ *.la)
+ name=`$echo "X$deplib" | $Xsed -e 's%^.*/%%'`
+@@ -5919,10 +5940,13 @@
+ # At present, this check doesn't affect windows .dll's that
+ # are installed into $libdir/../bin (currently, that works fine)
+ # but it's something to keep an eye on.
+- if test "$inst_prefix_dir" = "$destdir"; then
+- $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
+- exit $EXIT_FAILURE
+- fi
++ #
++ # This breaks install into our staging area. -PB
++ #
++ # if test "$inst_prefix_dir" = "$destdir"; then
++ # $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
++ # exit $EXIT_FAILURE
++ # fi
+
+ if test -n "$inst_prefix_dir"; then
+ # Stick the inst_prefix_dir data into the link command.