summaryrefslogtreecommitdiff
path: root/package/games/doom-wad
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-09-24 12:53:45 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-09-24 12:53:45 +0000
commit7108decafe79ff862837a1a7a8f447eed90eb28f (patch)
tree7c73b596d4dbe9e88dba8126c895ee2fb462ebab /package/games/doom-wad
parente40448aa34be9a626a031e893d51177d761a5c57 (diff)
doom-wad: split out and fix installation of Doom shareware wad file
This patch splits the installation of the shareware WAD file into a separate package. The wad file will also be installed into /usr/share/games/doom directory, since the client will search this directory when starting. The Makefile rule has also been altered to use tools defined by Buildroot to extract and install the wad file. The package is also multiple project safe now. Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Diffstat (limited to 'package/games/doom-wad')
-rw-r--r--package/games/doom-wad/Config.in7
-rw-r--r--package/games/doom-wad/doom-wads.mk35
2 files changed, 42 insertions, 0 deletions
diff --git a/package/games/doom-wad/Config.in b/package/games/doom-wad/Config.in
new file mode 100644
index 000000000..14d144d25
--- /dev/null
+++ b/package/games/doom-wad/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_DOOM_WAD
+ bool "shareware Doom WAD file"
+ depends on BR2_PACKAGE_LXDOOM
+ help
+ This will install the shareware wad data file for the doom game.
+
+ The wad file will be placed in the /usr/share/games/doom directory.
diff --git a/package/games/doom-wad/doom-wads.mk b/package/games/doom-wad/doom-wads.mk
new file mode 100644
index 000000000..d5ea01da6
--- /dev/null
+++ b/package/games/doom-wad/doom-wads.mk
@@ -0,0 +1,35 @@
+#############################################################
+#
+# doom-wad
+#
+#############################################################
+
+DOOM_WAD_VERSION = 1.8
+DOOM_WAD_SOURCE = doom-$(DOOM_WAD_VERSION).wad.gz
+DOOM_WAD_SITE = ftp://ftp.idsoftware.com/idstuff/doom/
+DOOM_WAD_DIR=$(BUILD_DIR)/doom-wad-$(DOOM_WAD_VERSION)
+
+$(DL_DIR)/$(DOOM_WAD_SOURCE):
+ $(WGET) -P $(DL_DIR) $(DOOM_WAD_SITE)/$(DOOM_WAD_SOURCE)
+
+doom-wad-source: $(DL_DIR)/$(DOOM_WAD_SOURCE)
+
+$(DOOM_WAD_DIR)/.unpacked: $(DL_DIR)/$(DOOM_WAD_SOURCE)
+ $(INSTALL) -D $(DL_DIR)/$(DOOM_WAD_SOURCE) $(DOOM_WAD_DIR)/$(DOOM_WAD_SOURCE)
+ $(ZCAT) $(DOOM_WAD_DIR)/$(DOOM_WAD_SOURCE) > \
+ $(DOOM_WAD_DIR)/doom-$(DOOM_WAD_VERSION).wad
+ touch $@
+
+$(TARGET_DIR)/usr/share/games/doom/doom1.wad: $(DOOM_WAD_DIR)/.unpacked
+ $(INSTALL) -D $(DOOM_WAD_DIR)/doom-$(DOOM_WAD_VERSION).wad $@
+
+doom-wad: $(TARGET_DIR)/usr/share/games/doom/doom1.wad
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_DOOM_WAD)),y)
+TARGETS+=doom-wad
+endif