summaryrefslogtreecommitdiff
path: root/package/games/gnuchess
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-08-29 13:27:37 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-08-29 13:27:37 +0000
commit1b5c1e7bdbdf496078a8556c2906919432f60d52 (patch)
tree0eb0f404efb85594de1dfb4e3d31856d04808faf /package/games/gnuchess
parent022b95d6ef7b303f6fbd48c220001674eec4717a (diff)
games: Move all games into games subdir
Moved all games into a subdir called games and then updated makefiles as necessary. If not one objects to this one then I will probably do the same for audio next. Daniel Laird
Diffstat (limited to 'package/games/gnuchess')
-rw-r--r--package/games/gnuchess/Config.in6
-rw-r--r--package/games/gnuchess/gnuchess-5.07.patch11
-rw-r--r--package/games/gnuchess/gnuchess.mk17
3 files changed, 34 insertions, 0 deletions
diff --git a/package/games/gnuchess/Config.in b/package/games/gnuchess/Config.in
new file mode 100644
index 000000000..cae05cbbb
--- /dev/null
+++ b/package/games/gnuchess/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_GNUCHESS
+ bool "gnuchess"
+ help
+ GNU Chess lets most modern computers play a full game of chess.
+
+ http://ftp.gnu.org/pub/gnu/chess
diff --git a/package/games/gnuchess/gnuchess-5.07.patch b/package/games/gnuchess/gnuchess-5.07.patch
new file mode 100644
index 000000000..18979b68c
--- /dev/null
+++ b/package/games/gnuchess/gnuchess-5.07.patch
@@ -0,0 +1,11 @@
+--- a/src/input.c 2003-07-01 13:06:43.000000000 -0400
++++ a/src/input.c 2008-02-13 12:24:43.000000000 -0500
+@@ -92,7 +92,7 @@ void getline_standard(char *p)
+ fgets(inputstr, MAXSTR, stdin);
+ }
+
+-static pthread_t input_thread;
++pthread_t input_thread;
+
+ /* Mutex and condition variable for thread communication */
+
diff --git a/package/games/gnuchess/gnuchess.mk b/package/games/gnuchess/gnuchess.mk
new file mode 100644
index 000000000..b1ff3b73a
--- /dev/null
+++ b/package/games/gnuchess/gnuchess.mk
@@ -0,0 +1,17 @@
+#############################################################
+#
+# gnuchess
+#
+#############################################################
+GNUCHESS_VERSION = 5.07
+GNUCHESS_SOURCE = gnuchess-$(GNUCHESS_VERSION).tar.gz
+GNUCHESS_SITE = $(BR2_GNU_MIRROR)/chess
+GNUCHESS_INSTALL_STAGING = NO
+GNUCHESS_INSTALL_TARGET = YES
+
+GNUCHESS_CONF_ENV = ac_cv_func_realloc_0_nonnull=yes ac_cv_func_malloc_0_nonnull=yes
+
+GNUCHESS_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package/games,gnuchess))
+