summaryrefslogtreecommitdiff
path: root/package/games
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-29 21:57:43 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-29 23:12:27 +0200
commit300f9c9c9dcf2b47ea89c45d5b1ea05e7305bd49 (patch)
tree4b06e56a40777a04ec56ba16d9b5d08fed84de08 /package/games
parent0849e8193ef429f29945b8c2a54eafc8635e0969 (diff)
package: remove useless arguments from AUTOTARGETS
Thanks to the pkgparentdir and pkgname functions, we can rewrite the AUTOTARGETS macro in a way that avoids the need for each package to repeat its name and the directory in which it is present. [Peter: pkgdir->pkgparentdir] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/games')
-rw-r--r--package/games/gnuchess/gnuchess.mk2
-rw-r--r--package/games/prboom/prboom.mk2
-rw-r--r--package/games/rubix/rubix.mk2
3 files changed, 3 insertions, 3 deletions
diff --git a/package/games/gnuchess/gnuchess.mk b/package/games/gnuchess/gnuchess.mk
index 8e331a469..a6278446c 100644
--- a/package/games/gnuchess/gnuchess.mk
+++ b/package/games/gnuchess/gnuchess.mk
@@ -9,5 +9,5 @@ GNUCHESS_SITE = $(BR2_GNU_MIRROR)/chess
GNUCHESS_DEPENDENCIES = $(if $(BR2_PACKAGE_READLINE),readline)
-$(eval $(call AUTOTARGETS,package/games,gnuchess))
+$(eval $(call AUTOTARGETS))
diff --git a/package/games/prboom/prboom.mk b/package/games/prboom/prboom.mk
index dd749dca1..9ffecee42 100644
--- a/package/games/prboom/prboom.mk
+++ b/package/games/prboom/prboom.mk
@@ -41,4 +41,4 @@ define PRBOOM_UINSTALL_TARGET_CMDS
$(TARGET_DIR)/usr/games/prboom
endef
-$(eval $(call AUTOTARGETS,package/games,prboom))
+$(eval $(call AUTOTARGETS))
diff --git a/package/games/rubix/rubix.mk b/package/games/rubix/rubix.mk
index 3440c2313..2fb051a1c 100644
--- a/package/games/rubix/rubix.mk
+++ b/package/games/rubix/rubix.mk
@@ -14,5 +14,5 @@ RUBIX_MAKE_OPT = CC="$(TARGET_CC)" XINC="-I$(STAGING_DIR)/usr/include/X11" XLIB=
RUBIX_DEPENDENCIES = xserver_xorg-server
-$(eval $(call AUTOTARGETS,package/games,rubix))
+$(eval $(call AUTOTARGETS))