summaryrefslogtreecommitdiff
path: root/package/games
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-10-14 21:40:47 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-10-14 21:40:47 +0200
commit9f8f3c92c634e5041769e608a64b680dfc074c80 (patch)
tree694e174c556d6e6b889d7df0530db6507e9fb05b /package/games
parentaecb5b4dc7cd1bcd54e9711b1b11a344fc6391dc (diff)
prboom: re-add big endian fixup
Seems I misread configure.ac, the endianness detection is only used when not cross compiling. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/games')
-rw-r--r--package/games/prboom/prboom.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/games/prboom/prboom.mk b/package/games/prboom/prboom.mk
index a8c7f6548..3a50fd502 100644
--- a/package/games/prboom/prboom.mk
+++ b/package/games/prboom/prboom.mk
@@ -19,6 +19,16 @@ PRBOOM_CONF_OPT = \
--disable-sdltest \
--disable-gl
+# endianness detection isn't used when cross compiling
+define PRBOOM_BIG_ENDIAN_FIXUP
+ $(SED) 's,.*#undef WORDS_BIGENDIAN.*,#define WORDS_BIGENDIAN 1,g' \
+ $(PRBOOM_DIR)/config.h
+endef
+
+ifeq ($(BR2_ENDIAN),"BIG")
+PRBOOM_POST_CONFIGURE_HOOKS += PRBOOM_BIG_ENDIAN_FIXUP
+endif
+
define PRBOOM_INSTALL_TARGET_CMDS
$(INSTALL) -D $(@D)/src/prboom $(TARGET_DIR)/usr/games/prboom
$(INSTALL) -D $(@D)/src/prboom-game-server $(TARGET_DIR)/usr/games/prboom-game-server