summaryrefslogtreecommitdiff
path: root/package/games
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-10-14 20:31:04 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-10-14 20:32:34 +0200
commitc4e6bc74de5ac03e74b797bbcd088977f166d484 (patch)
treedfb042e47af998cec560692dd9de9ffb5dfa8abf /package/games
parentdc6d5d9b3c3d626f15841829d59b059da960c2ff (diff)
prboom: fix png support
Ensure libpng gets built before prboom so configure finds it, and fix build with libpng 1.4.x (NULL defines removed). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/games')
-rw-r--r--package/games/prboom/prboom-2.5.0-libpng-1.4.patch32
-rw-r--r--package/games/prboom/prboom.mk4
2 files changed, 36 insertions, 0 deletions
diff --git a/package/games/prboom/prboom-2.5.0-libpng-1.4.patch b/package/games/prboom/prboom-2.5.0-libpng-1.4.patch
new file mode 100644
index 000000000..0d2a3a5ba
--- /dev/null
+++ b/package/games/prboom/prboom-2.5.0-libpng-1.4.patch
@@ -0,0 +1,32 @@
+[PATCH] fix build with libpng 1.4.x
+
+In 1.4.x the png_*_NULL defines are gone. Replace them with a normal
+NULL instead.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ src/SDL/i_sshot.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: prboom-2.5.0/src/SDL/i_sshot.c
+===================================================================
+--- prboom-2.5.0.orig/src/SDL/i_sshot.c
++++ prboom-2.5.0/src/SDL/i_sshot.c
+@@ -231,7 +231,7 @@ int I_ScreenShot (const char *fname)
+ if (fp)
+ {
+ png_struct *png_ptr = png_create_write_struct(
+- PNG_LIBPNG_VER_STRING, png_error_ptr_NULL, error_fn, warning_fn);
++ PNG_LIBPNG_VER_STRING, NULL, error_fn, warning_fn);
+
+ if (png_ptr)
+ {
+@@ -279,7 +279,7 @@ int I_ScreenShot (const char *fname)
+ break;
+ }
+ }
+- png_destroy_write_struct(&png_ptr, png_infopp_NULL);
++ png_destroy_write_struct(&png_ptr, NULL);
+ }
+ fclose(fp);
+ }
diff --git a/package/games/prboom/prboom.mk b/package/games/prboom/prboom.mk
index 651118cab..a8c7f6548 100644
--- a/package/games/prboom/prboom.mk
+++ b/package/games/prboom/prboom.mk
@@ -7,6 +7,10 @@ PRBOOM_VERSION = 2.5.0
PRBOOM_CONF_ENV = ac_cv_type_uid_t=yes
PRBOOM_DEPENDENCIES = sdl SDL_net sdl_mixer
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+PRBOOM_DEPENDENCIES += libpng
+endif
+
PRBOOM_CONF_OPT = \
--oldincludedir=$(STAGING_DIR)/usr/include \
--with-sdl-prefix=$(STAGING_DIR)/usr \