summaryrefslogtreecommitdiff
path: root/package/gdisk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-29 08:49:48 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-29 08:49:48 +0200
commite1fbd63f3c9700ef9d590ea7b4659ca592db5e3c (patch)
tree7b86200292e106ac9ac8b5d9ca363304b263fe45 /package/gdisk
parent7ee8ebbd813ad0a6d2392ef628c1724104f0619b (diff)
package: use libuuid from util-linux
And adjust users. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gdisk')
-rw-r--r--package/gdisk/Config.in18
-rw-r--r--package/gdisk/gdisk.mk2
2 files changed, 12 insertions, 8 deletions
diff --git a/package/gdisk/Config.in b/package/gdisk/Config.in
index 0daec5d5a..02bc188ff 100644
--- a/package/gdisk/Config.in
+++ b/package/gdisk/Config.in
@@ -1,6 +1,8 @@
config BR2_PACKAGE_GDISK
bool "gdisk"
- depends on BR2_LARGEFILE && BR2_INSTALL_LIBSTDCPP
+ depends on BR2_LARGEFILE
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_WCHAR # util-linux
help
GPT fdisk (consisting of the gdisk and sgdisk programs) is a
text-mode partitioning tool that works on Globally Unique Identifier
@@ -12,8 +14,9 @@ config BR2_PACKAGE_GDISK
config BR2_PACKAGE_GDISK_GDISK
bool "interactive gdisk"
depends on BR2_PACKAGE_GDISK
- select BR2_PACKAGE_E2FSPROGS
- select BR2_PACKAGE_E2FSPROGS_LIBUUID
+ select BR2_PACKAGE_BUSYBOX_SHOW_OTHERS # util-linux
+ select BR2_PACKAGE_UTIL_LINUX
+ select BR2_PACKAGE_UTIL_LINUX_LIBUUID
help
Install the interactive GUID partition table (GPT) manipulator
/usr/sbin/gdisk which is modelled after and quite similar in use
@@ -22,13 +25,14 @@ config BR2_PACKAGE_GDISK_GDISK
config BR2_PACKAGE_GDISK_SGDISK
bool "command line sgdisk"
depends on BR2_PACKAGE_GDISK
- select BR2_PACKAGE_E2FSPROGS
- select BR2_PACKAGE_E2FSPROGS_LIBUUID
+ select BR2_PACKAGE_BUSYBOX_SHOW_OTHERS # util-linux
+ select BR2_PACKAGE_UTIL_LINUX
+ select BR2_PACKAGE_UTIL_LINUX_LIBUUID
select BR2_PACKAGE_POPT
help
Install the command-line GUID partition table (GPT) manipulator
/usr/sbin/sgdisk which is named after the traditional MBR based
sfdisk tool albeit with an entirely different option syntax.
-comment "gdisk requires a toolchain with LARGEFILE and C++ support enabled"
- depends on !BR2_LARGEFILE || !BR2_INSTALL_LIBSTDCPP
+comment "gdisk requires a toolchain with LARGEFILE/WCHAR/C++ support enabled"
+ depends on !(BR2_LARGEFILE && BR2_INSTALL_LIBSTDCPP && BR2_USE_WCHAR)
diff --git a/package/gdisk/gdisk.mk b/package/gdisk/gdisk.mk
index ef4627d8e..bc7bc3253 100644
--- a/package/gdisk/gdisk.mk
+++ b/package/gdisk/gdisk.mk
@@ -13,7 +13,7 @@ GDISK_TARGETS_$(BR2_PACKAGE_GDISK_SGDISK) += sgdisk
ifneq ($(GDISK_TARGETS_y),)
-GDISK_DEPENDENCIES += e2fsprogs
+GDISK_DEPENDENCIES += util-linux
ifeq ($(BR2_PACKAGE_GDISK_SGDISK),y)
GDISK_DEPENDENCIES += popt
endif