summaryrefslogtreecommitdiff
path: root/package/gettext
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-15 21:28:15 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-15 21:28:15 +0000
commit58c49926d2e7f52df41ef3f804630260b599d4dd (patch)
treed39a0ef9162b744075aaa947568936029e664216 /package/gettext
parenta64b9018e0f849020f466534766c791c8bfbf85b (diff)
do not install build stuff into the target unless specifically asked to do so
Diffstat (limited to 'package/gettext')
-rw-r--r--package/gettext/gettext.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/gettext/gettext.mk b/package/gettext/gettext.mk
index 3da4cd9e1..7a7340c3b 100644
--- a/package/gettext/gettext.mk
+++ b/package/gettext/gettext.mk
@@ -137,12 +137,14 @@ gettext-target: $(GETTEXT_DIR)/$(GETTEXT_BINARY)
$(TARGET_DIR)/usr/include/libintl.h
-rmdir $(TARGET_DIR)/usr/include
-libintl: $(TARGET_DIR)/lib/libintl.so
-
$(TARGET_DIR)/lib/libintl.so: $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY)
- cp -a $(STAGING_DIR)/lib/libintl.so* $(TARGET_DIR)/lib
+ cp -a $(STAGING_DIR)/lib/libgettext*.so* $(TARGET_DIR)/lib/
+ cp -a $(STAGING_DIR)/lib/libintl*.so* $(TARGET_DIR)/lib/
+ rm -f $(TARGET_DIR)/lib/libgettext*.so*.la $(TARGET_DIR)/lib/libintl*.so*.la
touch $@
+libintl: $(TARGET_DIR)/lib/libintl.so
+
#############################################################
#
# Toplevel Makefile options
@@ -152,5 +154,5 @@ ifeq ($(strip $(BR2_PACKAGE_LIBINTL)),y)
TARGETS+=libintl
endif
ifeq ($(strip $(BR2_PACKAGE_GETTEXT)),y)
-TARGETS+=gettext-target
+TARGETS+=gettext
endif