summaryrefslogtreecommitdiff
path: root/package/gettext
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-16 10:00:29 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-16 10:00:29 +0000
commit5dce7d3005e1fe6c95cf67f096bf05e39651d226 (patch)
tree0a7071d79b08806b9105b7ae53010b22b902f805 /package/gettext
parent483331462a81070ac565a89f1c9091e7ad5628b4 (diff)
Temporarily allow static libgettext library option to ensure build can complete for ARM
Diffstat (limited to 'package/gettext')
-rw-r--r--package/gettext/Config.in13
-rw-r--r--package/gettext/gettext.mk14
2 files changed, 26 insertions, 1 deletions
diff --git a/package/gettext/Config.in b/package/gettext/Config.in
index 3c056d647..7e92a9622 100644
--- a/package/gettext/Config.in
+++ b/package/gettext/Config.in
@@ -8,6 +8,19 @@ config BR2_PACKAGE_GETTEXT
http://www.gnu.org/software/gettext/
+config BR2_PACKAGE_GETTEXT_STATIC
+ bool "Use libgettext.a instead of libgettext.so.*"
+ default y
+ depends on BR2_PACKAGE_GETTEXT
+ depends on BR2_arm
+ help
+ The GNU `gettext' utilities are a set of tools that provide a
+ framework to help other GNU packages produce multi-lingual
+ messages.
+
+ http://www.gnu.org/software/gettext/
+
+
config BR2_PACKAGE_LIBINTL
bool "libintl"
default n
diff --git a/package/gettext/gettext.mk b/package/gettext/gettext.mk
index 63bb2248b..f6c971941 100644
--- a/package/gettext/gettext.mk
+++ b/package/gettext/gettext.mk
@@ -11,6 +11,12 @@ GETTEXT_CAT:=$(ZCAT)
GETTEXT_BINARY:=gettext-runtime/src/gettext
GETTEXT_TARGET_BINARY:=usr/bin/gettext
+ifeq ($(strip $(BR2_PACKAGE_GETTEXT_STATIC)),y)
+LIBINTL_TARGET_BINARY:=usr/lib/libintl.a
+else
+LIBINTL_TARGET_BINARY:=usr/lib/libintl.so
+endif
+
$(DL_DIR)/$(GETTEXT_SOURCE):
$(WGET) -P $(DL_DIR) $(GETTEXT_SITE)/$(GETTEXT_SOURCE)
@@ -91,6 +97,7 @@ $(GETTEXT_DIR)/.configured: $(GETTEXT_DIR)/.unpacked
--prefix=/usr \
--exec-prefix=/usr \
--disable-libasprintf \
+ --enable-shared \
$(IGNORE_EXTERNAL_GETTEXT) \
$(OPENMP) \
);
@@ -144,7 +151,12 @@ $(TARGET_DIR)/usr/lib/libintl.so: $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY)
rm -f $(TARGET_DIR)/usr/lib/libgettext*.so*.la $(TARGET_DIR)/usr/lib/libintl*.so*.la
touch -c $@
-libintl: $(TARGET_DIR)/usr/lib/libintl.so
+$(TARGET_DIR)/usr/lib/libintl.a: $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY)
+ cp -dpf $(STAGING_DIR)/usr/lib/libgettext*.a $(TARGET_DIR)/usr/lib/
+ cp -dpf $(STAGING_DIR)/usr/lib/libintl*.a $(TARGET_DIR)/usr/lib/
+ touch -c $@
+
+libintl: $(TARGET_DIR)/$(LIBINTL_TARGET_BINARY)
#############################################################
#