summaryrefslogtreecommitdiff
path: root/package/hostapd/hostapd.mk
diff options
context:
space:
mode:
authorDaniel Mack <zonque@gmail.com>2011-12-03 18:03:29 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-26 08:41:36 +0100
commit11f7a7b4fb676ae6db33c03402e624ad5b5d6968 (patch)
treefe50b5298c505be925c8be22260f58eb40bd877d /package/hostapd/hostapd.mk
parent4f266b685f487d92208f07c0f5b2fa50e042bf06 (diff)
hostapd: fix build with new libnl-3
The CFLAGS have to be augmented for the include dir and a small patch will make the binary link to libnl-3 and libnl-genl-3 instead of libnl and libnl-gen. Signed-off-by: Daniel Mack <zonque@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/hostapd/hostapd.mk')
-rw-r--r--package/hostapd/hostapd.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/hostapd/hostapd.mk b/package/hostapd/hostapd.mk
index 0d6c2c53a..26ebf1de0 100644
--- a/package/hostapd/hostapd.mk
+++ b/package/hostapd/hostapd.mk
@@ -18,6 +18,7 @@ endif
define HOSTAPD_LIBNL_CONFIG
echo "CONFIG_LIBNL20=y" >>$(HOSTAPD_CONFIG)
+ echo "CFLAGS += -I$(STAGING_DIR)/usr/include/libnl3/" >>$(HOSTAPD_CONFIG)
endef
define HOSTAPD_CRYPTO_CONFIG