summaryrefslogtreecommitdiff
path: root/package/hotplug
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
commit44eedc5c44416a97b3f5ca03d596ec3c9fb29380 (patch)
tree96f605b4cd9934fc1d09319490c672aaab44ce2f /package/hotplug
parent73f7be82904f487d167493e76b415fbe5b5f8c5a (diff)
facelift step number two
Diffstat (limited to 'package/hotplug')
-rw-r--r--package/hotplug/hotplug.mk5
-rw-r--r--package/hotplug/hotplug.patch33
2 files changed, 35 insertions, 3 deletions
diff --git a/package/hotplug/hotplug.mk b/package/hotplug/hotplug.mk
index e13a6025d..ef38deec3 100644
--- a/package/hotplug/hotplug.mk
+++ b/package/hotplug/hotplug.mk
@@ -6,14 +6,13 @@
HOTPLUG_SOURCE=diethotplug-0.4.tar.gz
HOTPLUG_SITE=http://aleron.dl.sourceforge.net/sourceforge/linux-hotplug
HOTPLUG_DIR=$(BUILD_DIR)/diethotplug-0.4
-HOTPLUG_PATCH=$(SOURCE_DIR)/hotplug.patch
$(DL_DIR)/$(HOTPLUG_SOURCE):
$(WGET) -P $(DL_DIR) $(HOTPLUG_SITE)/$(HOTPLUG_SOURCE)
-$(HOTPLUG_DIR): $(DL_DIR)/$(HOTPLUG_SOURCE) $(HOTPLUG_PATCH)
+$(HOTPLUG_DIR): $(DL_DIR)/$(HOTPLUG_SOURCE)
zcat $(DL_DIR)/$(HOTPLUG_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- cat $(HOTPLUG_PATCH) | patch -p1 -d $(HOTPLUG_DIR)
+ toolchain/patch-kernel.sh $(HOTPLUG_DIR) package/hotplug/ hotplug\*.patch
$(HOTPLUG_DIR)/hotplug: $(HOTPLUG_DIR)
$(MAKE) CROSS=$(TARGET_CROSS) DEBUG=false KLIBC=false \
diff --git a/package/hotplug/hotplug.patch b/package/hotplug/hotplug.patch
new file mode 100644
index 000000000..22c356b22
--- /dev/null
+++ b/package/hotplug/hotplug.patch
@@ -0,0 +1,33 @@
+diff -urN diethotplug-0.4.orig/pci.c diethotplug-0.4/pci.c
+--- diethotplug-0.4.orig/pci.c Wed Jan 9 13:57:29 2002
++++ diethotplug-0.4/pci.c Wed Jan 30 22:35:24 2002
+@@ -68,8 +68,8 @@
+ }
+
+ /* check that the class matches */
+- class_temp = pci_module_map[i].class_mask & pci_class;
+- if (pci_module_map[i].class != class_temp) {
++ class_temp = (pci_module_map[i].class ^ pci_class) & pci_module_map[i].class_mask;
++ if (class_temp != 0) {
+ dbg ("class mask check failed %x != %x",
+ pci_module_map[i].class, class_temp);
+ continue;
+--- diethotplug-0.4/Makefile.orig Wed Jan 9 14:28:05 2002
++++ diethotplug-0.4/Makefile Mon Jul 8 07:29:00 2002
+@@ -135,13 +135,13 @@
+
+ # Rules on how to create the generated header files
+ usb_modules.h:
+- perl convert_usb.pl < /lib/modules/$(KERNEL_VERSION)/modules.usbmap > $@
++ perl convert_usb.pl < $(TARGET_DIR)/lib/modules/$(KERNEL_VERSION)/modules.usbmap > $@
+
+ pci_modules.h:
+- perl convert_pci.pl < /lib/modules/$(KERNEL_VERSION)/modules.pcimap > $@
++ perl convert_pci.pl < $(TARGET_DIR)/lib/modules/$(KERNEL_VERSION)/modules.pcimap > $@
+
+ ieee1394_modules.h:
+- perl convert_ieee1394.pl < /lib/modules/$(KERNEL_VERSION)/modules.ieee1394map > $@
++ perl convert_ieee1394.pl < $(TARGET_DIR)/lib/modules/$(KERNEL_VERSION)/modules.ieee1394map > $@
+
+ hotplug_version.h:
+ @echo \#define HOTPLUG_VERSION \"$(VERSION)\" > $@