summaryrefslogtreecommitdiff
path: root/package/imagemagick/imagemagick.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-22 18:25:20 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-22 22:14:36 +0100
commitc5a195e4038af111fafc452e030e2a0a83ec1d9e (patch)
treee378ffad6981751d117751f68d61289460d2aaf2 /package/imagemagick/imagemagick.mk
parent4c31d75ca447c9d27cd57233caffedef1c36ee4b (diff)
imagemagick: add patch to fix libxml2 issue and remove useless patch
The patch imagemagick-6.6.4-add-errno-h-if-argz-h-does-not-exist.patch was not applied anymore due to a difference in the version number, and it didn't prevent imagemagick to be built. It was introduced several years ago together with the ImageMagick package itself, so presumably it is no longer needed. The new patch allows ImageMagick to use the correct xml2-config script to get the proper location for XML2 headers and libraries. Otherwise, -I/usr/include/libxml2 is found in the compile flags. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/imagemagick/imagemagick.mk')
-rw-r--r--package/imagemagick/imagemagick.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/imagemagick/imagemagick.mk b/package/imagemagick/imagemagick.mk
index 30158e009..aecf7ae20 100644
--- a/package/imagemagick/imagemagick.mk
+++ b/package/imagemagick/imagemagick.mk
@@ -9,6 +9,7 @@ IMAGEMAGICK_SOURCE = ImageMagick-$(IMAGEMAGICK_VERSION).tar.bz2
IMAGEMAGICK_SITE = ftp://ftp.imagemagick.org/pub/ImageMagick
IMAGEMAGICK_LIBTOOL_PATCH = NO
IMAGEMAGICK_INSTALL_STAGING = YES
+IMAGEMAGICK_AUTORECONF = YES
ifeq ($(BR2_LARGEFILE),y)
IMAGEMAGICK_CONF_ENV = ac_cv_sys_file_offset_bits=64
@@ -66,6 +67,7 @@ endif
ifeq ($(BR2_PACKAGE_LIBXML2),y)
IMAGEMAGICK_CONF_OPT += --with-xml
+IMAGEMAGICK_CONF_ENV += ac_cv_prog_xml2_config=$(STAGING_DIR)/usr/bin/xml2-config
IMAGEMAGICK_DEPENDENCIES += libxml2
else
IMAGEMAGICK_CONF_OPT += --without-xml