summaryrefslogtreecommitdiff
path: root/package/java
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-06-15 20:46:43 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-06-15 20:48:50 +0200
commit676032036b45edbe614ced6c7dc48bf7d29a3e1f (patch)
treec992632c534e768b3acd1a153740bc5e26374ac9 /package/java
parent220dca451ef4b2f680ca35caacb29f6a6138068a (diff)
Upgrade classpath version and fix compilation
* Upgrade to version 0.98 * Use --disable-Werror, otherwise it doesn't build since warnings are treated as errors * Don't depend on tiff, which isn't mandatory, and doesn't build. Once tiff is fixed, we can re-add it as a dependency.
Diffstat (limited to 'package/java')
-rw-r--r--package/java/classpath/classpath.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/java/classpath/classpath.mk b/package/java/classpath/classpath.mk
index faa634143..71c18a045 100644
--- a/package/java/classpath/classpath.mk
+++ b/package/java/classpath/classpath.mk
@@ -3,7 +3,7 @@
# classpath 0.96.1
#
#############################################################
-CLASSPATH_VERSION = 0.97.1
+CLASSPATH_VERSION = 0.98
CLASSPATH_SOURCE = classpath-$(CLASSPATH_VERSION).tar.gz
CLASSPATH_SITE = $(BR2_GNU_MIRROR)/classpath
CLASSPATH_AUTORECONF = NO
@@ -51,9 +51,10 @@ CLASSPATH_CONF_OPT = \
--enable-static \
--disable-glibtest --enable-explicit-deps=no \
--disable-debug \
- --disable-gconf-peer --disable-examples --disable-plugin
+ --disable-gconf-peer --disable-examples --disable-plugin \
+ --disable-Werror
-CLASSPATH_DEPENDENCIES = uclibc host-pkgconfig libpng jpeg tiff
+CLASSPATH_DEPENDENCIES = uclibc host-pkgconfig libpng jpeg
ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
CLASSPATH_DEPENDENCIES+= alsa-lib