summaryrefslogtreecommitdiff
path: root/package/java
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-17 15:42:40 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-24 23:26:47 +0200
commit6beeb755fa41a24ef54c189b8ae723534fa15c92 (patch)
tree7f6a13d143fb680a7a8b75f1f83e6a24c1118372 /package/java
parentf2d8a44f263c24ff7858ed26e91f2505c8b66dd7 (diff)
xorg: use BR2_PACKAGE_XORG instead of BR2_PACKAGE_XSERVER_none
The BR2_PACKAGE_XSERVER_none option has gone, so use BR2_PACKAGE_XORG7 instead. It is more logical to test if BR2_PACKAGE_XORG7 is set to know if an X.org server is available, than testing if BR2_PACKAGE_XSERVER_none is set to know if an X.org server is *not* available. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/java')
-rw-r--r--package/java/classpath/classpath.mk2
-rw-r--r--package/java/jamvm/jamvm.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/java/classpath/classpath.mk b/package/java/classpath/classpath.mk
index 71c18a045..b62e29c1b 100644
--- a/package/java/classpath/classpath.mk
+++ b/package/java/classpath/classpath.mk
@@ -77,7 +77,7 @@ else
CLASSPATH_CONF_OPT+= --disable-gtk-peer
endif
-ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ifeq ($(BR2_PACKAGE_XORG7),y)
CLASSPATH_DEPENDENCIES+= $(XSERVER)
CLASSPATH_CONF_OPT+= --with-x \
--x-includes=$(STAGING_DIR)/usr/include/X11 \
diff --git a/package/java/jamvm/jamvm.mk b/package/java/jamvm/jamvm.mk
index dff089af4..92ae4a6d7 100644
--- a/package/java/jamvm/jamvm.mk
+++ b/package/java/jamvm/jamvm.mk
@@ -52,7 +52,7 @@ JAMVM_CONF_OPT = \
JAMVM_DEPENDENCIES = uclibc host-pkgconfig classpath
#Include X libraries when we have an X server
-ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ifeq ($(BR2_PACKAGE_XORG7),y)
JAMVM_DEPENDENCIES+= $(XSERVER)
JAMVM_CONF_OPT+= --with-x \
--x-includes=$(STAGING_DIR)/usr/include/X11 \