summaryrefslogtreecommitdiff
path: root/package/java
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
commit77754571b2f327636ce0072cfabc9ce0c9a6ad86 (patch)
tree56fc2d3552653caaa20ee7577b1a04375f80bf28 /package/java
parent344d59d788d697f4f6704dd920cad615318e47be (diff)
pkgconfig: add pkgconfig package for target
The host versions shouldn't be visible in Kconfig, so remove the reference to BR2_PACKAGE_PKGCONFIG everywhere and prefix the host targets with host-. At the same time add pkgconfig for the target (E.G. for development) and let BR2_PACKAGE_PKGCONFIG control that package. Notice: all defconfigs in the tree have been updated, but make sure to disable the pkgconfig package (unless you want it) if you use an external config, otherwise you'll end up with pkgconfig and glib2 in the target.
Diffstat (limited to 'package/java')
-rw-r--r--package/java/classpath/Config.in1
-rw-r--r--package/java/classpath/classpath.mk2
-rw-r--r--package/java/jamvm/Config.in1
-rw-r--r--package/java/jamvm/jamvm.mk2
4 files changed, 2 insertions, 4 deletions
diff --git a/package/java/classpath/Config.in b/package/java/classpath/Config.in
index 33837636d..c6b5e5280 100644
--- a/package/java/classpath/Config.in
+++ b/package/java/classpath/Config.in
@@ -1,6 +1,5 @@
config BR2_PACKAGE_CLASSPATH
bool "classpath"
- select BR2_PACKAGE_PKGCONFIG
help
GNU Classpath, Essential Libraries for Java, is a GNU
diff --git a/package/java/classpath/classpath.mk b/package/java/classpath/classpath.mk
index 367b3d802..faa634143 100644
--- a/package/java/classpath/classpath.mk
+++ b/package/java/classpath/classpath.mk
@@ -53,7 +53,7 @@ CLASSPATH_CONF_OPT = \
--disable-debug \
--disable-gconf-peer --disable-examples --disable-plugin
-CLASSPATH_DEPENDENCIES = uclibc pkgconfig libpng jpeg tiff
+CLASSPATH_DEPENDENCIES = uclibc host-pkgconfig libpng jpeg tiff
ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
CLASSPATH_DEPENDENCIES+= alsa-lib
diff --git a/package/java/jamvm/Config.in b/package/java/jamvm/Config.in
index 6e166dc42..59ac593aa 100644
--- a/package/java/jamvm/Config.in
+++ b/package/java/jamvm/Config.in
@@ -1,7 +1,6 @@
config BR2_PACKAGE_JAMVM
bool "jamvm"
depends on BR2_PACKAGE_CLASSPATH
- select BR2_PACKAGE_PKGCONFIG
help
JamVM is a new Java Virtual Machine which conforms to
the JVM specification version 2 (blue book).
diff --git a/package/java/jamvm/jamvm.mk b/package/java/jamvm/jamvm.mk
index 560be3470..dff089af4 100644
--- a/package/java/jamvm/jamvm.mk
+++ b/package/java/jamvm/jamvm.mk
@@ -49,7 +49,7 @@ JAMVM_CONF_OPT = \
--disable-debug --with-classpath-install-dir=/usr
-JAMVM_DEPENDENCIES = uclibc pkgconfig classpath
+JAMVM_DEPENDENCIES = uclibc host-pkgconfig classpath
#Include X libraries when we have an X server
ifneq ($(BR2_PACKAGE_XSERVER_none),y)