summaryrefslogtreecommitdiff
path: root/package/jquery-sparkline
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-12-18 23:40:11 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-18 23:40:11 +0100
commit645ff758fea4c640d1afc8d1a00da1a5f0b076ab (patch)
tree223fb38e38a3e8c48708aa0b279466e63d0223c1 /package/jquery-sparkline
parent50e00c3b6d2a40ea69716cb3df160a40892e19fe (diff)
package: add jQuery sparkline plugin
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/jquery-sparkline')
-rw-r--r--package/jquery-sparkline/Config.in13
-rw-r--r--package/jquery-sparkline/jquery-sparkline.mk18
2 files changed, 31 insertions, 0 deletions
diff --git a/package/jquery-sparkline/Config.in b/package/jquery-sparkline/Config.in
new file mode 100644
index 000000000..ae66364aa
--- /dev/null
+++ b/package/jquery-sparkline/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_JQUERY_SPARKLINE
+ bool "jQuery-Sparkline"
+ select BR2_PACKAGE_JQUERY
+ help
+ This jQuery plugin generates sparklines (small inline
+ charts) directly in the browser using data supplied either
+ inline in the HTML, or via javascript.
+
+ The plugin is compatible with most modern browsers and has
+ been tested with Firefox 2+, Safari 3+, Opera 9, Google
+ Chrome and Internet Explorer 6, 7 & 8.
+
+ http://www.omnipotent.net/jquery.sparkline/
diff --git a/package/jquery-sparkline/jquery-sparkline.mk b/package/jquery-sparkline/jquery-sparkline.mk
new file mode 100644
index 000000000..93dddf094
--- /dev/null
+++ b/package/jquery-sparkline/jquery-sparkline.mk
@@ -0,0 +1,18 @@
+JQUERY_SPARKLINE_VERSION = 1.6
+JQUERY_SPARKLINE_SITE = http://www.omnipotent.net/jquery.sparkline/$(JQUERY_SPARKLINE_VERSION)
+JQUERY_SPARKLINE_SOURCE = jquery.sparkline.min.js
+
+define JQUERY_SPARKLINE_EXTRACT_CMDS
+ cp $(DL_DIR)/$(JQUERY_SPARKLINE_SOURCE) $(@D)
+endef
+
+define JQUERY_SPARKLINE_INSTALL_TARGET_CMDS
+ $(INSTALL) -D $(@D)/$(JQUERY_SPARKLINE_SOURCE) \
+ $(TARGET_DIR)/var/www/jquery.sparkline.js
+endef
+
+define JQUERY_SPARKLINE_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/var/www/jquery.sparkline.js
+endef
+
+$(eval $(call GENTARGETS))