summaryrefslogtreecommitdiff
path: root/package/libcgi
diff options
context:
space:
mode:
authorSagaert Johan <sagaert.johan@skynet.be>2011-12-10 11:46:29 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-11 23:15:49 +0100
commite1d1c379e9f9aad3956f19a2c3d67eb7701cb48f (patch)
treec397d9d2367e8e2e8b82af344f09247e49d3bee1 /package/libcgi
parent190ec1134b69750b493ed356a9ff6b871c8fa09e (diff)
libcgi: build for target, not host
[Peter: Ensure correct CFLAGS are used, whitespace cleanup] Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libcgi')
-rw-r--r--package/libcgi/libcgi.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/libcgi/libcgi.mk b/package/libcgi/libcgi.mk
index 5867ff99d..5a52fa613 100644
--- a/package/libcgi/libcgi.mk
+++ b/package/libcgi/libcgi.mk
@@ -3,9 +3,11 @@
# libcgi
#
#############################################################
-LIBCGI_VERSION:=1.0
-LIBCGI_SOURCE:=libcgi-$(LIBCGI_VERSION).tar.gz
-LIBCGI_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/libcgi
-LIBCGI_INSTALL_STAGING=YES
+
+LIBCGI_VERSION = 1.0
+LIBCGI_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/libcgi
+LIBCGI_INSTALL_STAGING = YES
+# use cross CC/AR rather than host
+LIBCGI_MAKE_ENV = CC="$(TARGET_CC) $(TARGET_CFLAGS)" AR="$(TARGET_AR)"
$(eval $(call AUTOTARGETS))