summaryrefslogtreecommitdiff
path: root/package/libfuse/libfuse.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-19 22:53:04 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-20 22:42:05 +0200
commit29a2f3d21be89ddbdffb53cfb20a504d44a09c27 (patch)
tree598d15d483ef3a1ba2ea0ac90841862e5662fc65 /package/libfuse/libfuse.mk
parentc2a43fb12a089453f0054a53905ec11406ec93ba (diff)
libfuse: rename fuse to libfuse
We rename the package/fuse directory to package/libfuse to be consistent with the package name. This is needed for a future commit that will simplify the AUTOTARGETS macro by making assumptions on the directory name. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libfuse/libfuse.mk')
-rw-r--r--package/libfuse/libfuse.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/libfuse/libfuse.mk b/package/libfuse/libfuse.mk
new file mode 100644
index 000000000..86e57ff9a
--- /dev/null
+++ b/package/libfuse/libfuse.mk
@@ -0,0 +1,29 @@
+#############################################################
+#
+# libfuse
+#
+#############################################################
+
+LIBFUSE_VERSION = 2.8.6
+LIBFUSE_SOURCE = fuse-$(LIBFUSE_VERSION).tar.gz
+LIBFUSE_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/fuse/
+
+LIBFUSE_INSTALL_STAGING = YES
+LIBFUSE_CONF_OPT= --disable-nls \
+ --disable-example \
+ --disable-kernel-module \
+ --enable-lib \
+ --enable-util
+
+define LIBFUSE_INSTALL_TARGET_CMDS
+ cp -dpf $(STAGING_DIR)/usr/bin/fusermount $(TARGET_DIR)/usr/bin/
+ cp -dpf $(STAGING_DIR)/usr/lib/libfuse.so* $(TARGET_DIR)/usr/lib/
+endef
+
+define LIBFUSE_CLEAN_CMDS
+ -$(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) uninstall
+ -$(MAKE) -C $(@D) clean
+ rm -f $(TARGET_DIR)/usr/bin/fusermount $(TARGET_DIR)/usr/lib/libfuse.so*
+endef
+
+$(eval $(call AUTOTARGETS,package,libfuse))