summaryrefslogtreecommitdiff
path: root/package/libtool
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
commit73f7be82904f487d167493e76b415fbe5b5f8c5a (patch)
tree8d9acaf4414892fad533fd92ebfc7e65a2ad2785 /package/libtool
parent0b5ad783691ef6fa1285c8d7858a51c425a8b38d (diff)
Remove the old 'make' directory, and populate the new 'package'
directory.
Diffstat (limited to 'package/libtool')
-rw-r--r--package/libtool/libtool.mk77
1 files changed, 77 insertions, 0 deletions
diff --git a/package/libtool/libtool.mk b/package/libtool/libtool.mk
new file mode 100644
index 000000000..fbee18e74
--- /dev/null
+++ b/package/libtool/libtool.mk
@@ -0,0 +1,77 @@
+#############################################################
+#
+# libtool
+#
+#############################################################
+LIBTOOL_SOURCE:=libtool-1.5.8.tar.gz
+LIBTOOL_SITE:=ftp://ftp.gnu.org/gnu/libtool
+LIBTOOL_CAT:=zcat
+LIBTOOL_DIR:=$(BUILD_DIR)/libtool-1.5.8
+LIBTOOL_BINARY:=libtool
+LIBTOOL_TARGET_BINARY:=usr/bin/libtool
+
+$(DL_DIR)/$(LIBTOOL_SOURCE):
+ $(WGET) -P $(DL_DIR) $(LIBTOOL_SITE)/$(LIBTOOL_SOURCE)
+
+libtool-source: $(DL_DIR)/$(LIBTOOL_SOURCE)
+
+$(LIBTOOL_DIR)/.unpacked: $(DL_DIR)/$(LIBTOOL_SOURCE)
+ $(LIBTOOL_CAT) $(DL_DIR)/$(LIBTOOL_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ touch $(LIBTOOL_DIR)/.unpacked
+
+$(LIBTOOL_DIR)/.configured: $(LIBTOOL_DIR)/.unpacked
+ (cd $(LIBTOOL_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ $(DISABLE_NLS) \
+ );
+ touch $(LIBTOOL_DIR)/.configured
+
+$(LIBTOOL_DIR)/$(LIBTOOL_BINARY): $(LIBTOOL_DIR)/.configured
+ $(MAKE) CC=$(TARGET_CC) -C $(LIBTOOL_DIR)
+ touch -c $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
+
+$(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY): $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
+ $(MAKE) \
+ prefix=$(TARGET_DIR)/usr \
+ exec_prefix=$(TARGET_DIR)/usr \
+ bindir=$(TARGET_DIR)/usr/bin \
+ sbindir=$(TARGET_DIR)/usr/sbin \
+ libexecdir=$(TARGET_DIR)/usr/lib \
+ datadir=$(TARGET_DIR)/usr/share \
+ sysconfdir=$(TARGET_DIR)/etc \
+ localstatedir=$(TARGET_DIR)/var \
+ libdir=$(TARGET_DIR)/usr/lib \
+ infodir=$(TARGET_DIR)/usr/info \
+ mandir=$(TARGET_DIR)/usr/man \
+ includedir=$(TARGET_DIR)/usr/include \
+ -C $(LIBTOOL_DIR) install;
+ $(STRIP) $(TARGET_DIR)//usr/lib/libltdl.so.*.*.* > /dev/null 2>&1
+ $(SED) "s,^CC.*,CC=\"/usr/bin/gcc\"," $(TARGET_DIR)/usr/bin/libtool
+ $(SED) "s,^LD.*,LD=\"/usr/bin/ld\"," $(TARGET_DIR)/usr/bin/libtool
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+
+libtool: uclibc $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY)
+
+libtool-clean:
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(LIBTOOL_DIR) uninstall
+ -$(MAKE) -C $(LIBTOOL_DIR) clean
+
+libtool-dirclean:
+ rm -rf $(LIBTOOL_DIR)
+