summaryrefslogtreecommitdiff
path: root/package/libvorbis/libvorbis.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-06-16 11:34:29 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-06-16 11:34:29 +0000
commitb1af0e64b14e040af743e0f029aacff42615a1a4 (patch)
tree485e1b6ee3a4f11d9b690a0f9d6a3d25d5070ec3 /package/libvorbis/libvorbis.mk
parent15c2bc40adcc13da6259aa3a53c00c49e765af81 (diff)
libvorbis: remove BR2_PACKAGE_LIBVORBIS_HEADERS
We don't need per-package header install options now that we have BR2_HAVE_DEVFILES (they are in fact useless as the files will get overwritten/deleted anyway).
Diffstat (limited to 'package/libvorbis/libvorbis.mk')
-rw-r--r--package/libvorbis/libvorbis.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/package/libvorbis/libvorbis.mk b/package/libvorbis/libvorbis.mk
index b6358778a..3e496d938 100644
--- a/package/libvorbis/libvorbis.mk
+++ b/package/libvorbis/libvorbis.mk
@@ -47,15 +47,6 @@ $(TARGET_DIR)/usr/lib/libvorbis.so: $(LIBVORBIS_DIR)/.libs
$(MAKE) prefix=$(TARGET_DIR)/usr -C $(LIBVORBIS_DIR) install
touch $@
-$(TARGET_DIR)/usr/lib/libvorbis.a: $(TARGET_DIR)/usr/lib/libvorbis.so
- cp -dpf $(LIBVORBIS_DIR)/lib/libvorbis.a $(TARGET_DIR)/usr/lib/
- touch $@
-
-libvorbis-header: $(TARGET_DIR)/usr/lib/libvorbis.a
- mkdir -p $(TARGET_DIR)/usr/include/vorbis
- cp -dpf $(LIBVORBIS_DIR)/include/vorbis/*.h \
- $(TARGET_DIR)/usr/include/vorbis
-
libvorbis: uclibc pkgconfig libogg $(TARGET_DIR)/usr/lib/libvorbis.so
libvorbis-source: $(DL_DIR)/$(LIBVORBIS_SOURCE)
@@ -124,11 +115,6 @@ $(TARGET_DIR)/usr/lib/tremor.a: $(TARGET_DIR)/usr/lib/tremor.so
cp -dpf $(TREMOR_DIR)/lib/tremor.a $(TARGET_DIR)/usr/lib/
touch $@
-tremor-header: $(TARGET_DIR)/usr/lib/tremor.a
- mkdir -p $(TARGET_DIR)/usr/include/vorbis
- cp -dpf $(TREMOR_DIR)/include/vorbis/*.h \
- $(TARGET_DIR)/usr/include/vorbis
-
tremor: uclibc pkgconfig libogg $(TARGET_DIR)/usr/lib/tremor.so
tremor-source: $(DL_DIR)/$(TREMOR_SOURCE)
@@ -152,7 +138,3 @@ TARGETS+=tremor
endif
TARGETS+=libvorbis
endif
-
-ifeq ($(strip $(BR2_PACKAGE_LIBVORBIS_HEADERS)),y)
-TARGETS+=libvorbis-header
-endif