summaryrefslogtreecommitdiff
path: root/package/libxml2
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-07 17:27:59 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-07 17:27:59 +0000
commite1875d3ba2d3fc81505978996e4c54160ab6f7b1 (patch)
treee716bd8007423b32e8e2503a95ab54566f0a1eaf /package/libxml2
parent39435919e8b8a0b6528eb70b0f3b1c1fd31544a2 (diff)
Cleanup libxml2
Diffstat (limited to 'package/libxml2')
-rw-r--r--package/libxml2/Config.in6
-rw-r--r--package/libxml2/libxml2.mk19
2 files changed, 20 insertions, 5 deletions
diff --git a/package/libxml2/Config.in b/package/libxml2/Config.in
index 8c252b09d..0e383d682 100644
--- a/package/libxml2/Config.in
+++ b/package/libxml2/Config.in
@@ -1,19 +1,15 @@
config BR2_PACKAGE_LIBXML2
bool "libxml2"
default n
- depends on BR2_USE_WCHAR
help
XML C Parser
- Requires WCHAR
-
ftp://xmlsoft.org/libxml2
config BR2_PACKAGE_LIBXML2_TARGET_HEADERS
bool "libxml2 target headers"
default n
+ depends on BR2_PACKAGE_LIBXML2
help
XML C Parser
- Requires WCHAR
-
ftp://xmlsoft.org/libxml2
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index d9e2a35e6..17bba150b 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -26,8 +26,23 @@ $(LIBXML2_DIR)/.configured: $(LIBXML2_DIR)/.unpacked
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
--sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --includedir=/usr/include \
+ --with-gnu-ld \
--enable-shared \
+ --enable-static \
+ --enable-ipv6=no \
+ --without-debugging \
+ --without-python \
+ --without-threads \
$(DISABLE_NLS) \
);
touch $(LIBXML2_DIR)/.configured
@@ -38,6 +53,10 @@ $(LIBXML2_DIR)/libxml2.la: $(LIBXML2_DIR)/.configured
$(STAGING_DIR)/usr/lib/libxml2.so: $(LIBXML2_DIR)/libxml2.la
$(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBXML2_DIR) install
+ rm -f $(STAGING_DIR)/usr/lib/libxml2.la
+ $(SED) 's:prefix=/usr:prefix=$(STAGING_DIR)/usr:' \
+ -e 's:includedir=/usr/include:includedir=$(STAGING_DIR)/usr/include:' \
+ $(STAGING_DIR)/usr/bin/xml2-config
$(TARGET_DIR)/usr/lib/libxml2.so: $(STAGING_DIR)/usr/lib/libxml2.so
cp -dpf $(STAGING_DIR)/usr/lib/libxml2.so* $(TARGET_DIR)/usr/lib/