summaryrefslogtreecommitdiff
path: root/package/lighttpd/lighttpd.mk
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-07-21 19:47:51 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-22 18:44:10 +0200
commit853545c835e819c689862e8941f7d7c1a8bb4be0 (patch)
treed7b3fddedbd8148e38dea282776361cb4663923e /package/lighttpd/lighttpd.mk
parent6b36d541184f47e7c8d5a0d56766462169878bf4 (diff)
lighttpd: use standard web root directory
Signed-off-by: Simon Dawson <spdawson@gmail.com> Acked-By: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lighttpd/lighttpd.mk')
-rw-r--r--package/lighttpd/lighttpd.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index 5ff4ce65b..48f733a3d 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -57,9 +57,8 @@ LIGHTTPD_CONF_OPT += --without-lua
endif
define LIGHTTPD_INSTALL_CONFIG
- mkdir -p $(TARGET_DIR)/etc/lighttpd
- mkdir -p $(TARGET_DIR)/etc/lighttpd/conf.d
- mkdir -p $(TARGET_DIR)/srv/www/htdocs
+ $(INSTALL) -d -m 0755 $(TARGET_DIR)/etc/lighttpd/conf.d
+ $(INSTALL) -d -m 0755 $(TARGET_DIR)/var/www
[ -f $(TARGET_DIR)/etc/lighttpd/lighttpd.conf ] || \
$(INSTALL) -D -m 755 $(@D)/doc/config/lighttpd.conf \
@@ -89,9 +88,9 @@ endef
LIGHTTPD_POST_INSTALL_TARGET_HOOKS += LIGHTTPD_INSTALL_CONFIG
define LIGHTTPD_UNINSTALL_TARGET_CMDS
- rm -f $(TARGET_DIR)/usr/sbin/lighttpd
- rm -f $(TARGET_DIR)/usr/sbin/lighttpd-angel
- rm -rf $(TARGET_DIR)/usr/lib/lighttpd
+ $(RM) $(TARGET_DIR)/usr/sbin/lighttpd
+ $(RM) $(TARGET_DIR)/usr/sbin/lighttpd-angel
+ $(RM) -r $(TARGET_DIR)/usr/lib/lighttpd
endef
$(eval $(autotools-package))