summaryrefslogtreecommitdiff
path: root/package/ltp-testsuite
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
commit44eedc5c44416a97b3f5ca03d596ec3c9fb29380 (patch)
tree96f605b4cd9934fc1d09319490c672aaab44ce2f /package/ltp-testsuite
parent73f7be82904f487d167493e76b415fbe5b5f8c5a (diff)
facelift step number two
Diffstat (limited to 'package/ltp-testsuite')
-rw-r--r--package/ltp-testsuite/ltp-testsuite.mk3
-rw-r--r--package/ltp-testsuite/ltp-testsuite.patch49
2 files changed, 50 insertions, 2 deletions
diff --git a/package/ltp-testsuite/ltp-testsuite.mk b/package/ltp-testsuite/ltp-testsuite.mk
index 43c897c8a..30629619c 100644
--- a/package/ltp-testsuite/ltp-testsuite.mk
+++ b/package/ltp-testsuite/ltp-testsuite.mk
@@ -7,7 +7,6 @@ LTP_TESTSUITE_SOURCE:=ltp-full-20040506.tgz
LTP_TESTSUITE_SITE:=http://aleron.dl.sourceforge.net/sourceforge/ltp
LTP_TESTSUITE_CAT:=zcat
LTP_TESTSUITE_DIR:=$(BUILD_DIR)/ltp-full-20040506
-LTP_TESTSUITE_PATCH:=$(SOURCE_DIR)/ltp-testsuite.patch
$(DL_DIR)/$(LTP_TESTSUITE_SOURCE):
@@ -17,7 +16,7 @@ ltp-testsuite-source: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
$(LTP_TESTSUITE_DIR)/.unpacked: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
$(LTP_TESTSUITE_CAT) $(DL_DIR)/$(LTP_TESTSUITE_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- cat $(LTP_TESTSUITE_PATCH) | patch -p1 -d $(LTP_TESTSUITE_DIR)
+ toolchain/patch-kernel.sh $(LTP_TESTSUITE_DIR) package/ltp-testsuite/ ltp-testsuite-\*.patch
touch $(LTP_TESTSUITE_DIR)/.unpacked
$(LTP_TESTSUITE_DIR)/ltp-testsuite: $(LTP_TESTSUITE_DIR)/.unpacked
diff --git a/package/ltp-testsuite/ltp-testsuite.patch b/package/ltp-testsuite/ltp-testsuite.patch
new file mode 100644
index 000000000..baad6d6f5
--- /dev/null
+++ b/package/ltp-testsuite/ltp-testsuite.patch
@@ -0,0 +1,49 @@
+diff -urN ltp-full-20040506.orig/testcases/kernel/syscalls/fmtmsg/Makefile ltp-full-20040506/testcases/kernel/syscalls/fmtmsg/Makefile
+--- ltp-full-20040506.orig/testcases/kernel/syscalls/fmtmsg/Makefile 2003-03-04 09:15:27.000000000 -0700
++++ ltp-full-20040506/testcases/kernel/syscalls/fmtmsg/Makefile 2004-05-12 14:03:56.000000000 -0600
+@@ -24,7 +24,7 @@
+ LOADLIBES+= -L../../../../lib -lltp
+
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+diff -urN ltp-full-20040506.orig/testcases/kernel/syscalls/profil/Makefile ltp-full-20040506/testcases/kernel/syscalls/profil/Makefile
+--- ltp-full-20040506.orig/testcases/kernel/syscalls/profil/Makefile 2003-03-04 09:16:26.000000000 -0700
++++ ltp-full-20040506/testcases/kernel/syscalls/profil/Makefile 2004-05-12 14:03:56.000000000 -0600
+@@ -23,7 +23,7 @@
+ LOADLIBES+= -L../../../../lib -lltp
+
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+diff -urN ltp-full-20040506.orig/testcases/kernel/syscalls/swapon/swapon02.c ltp-full-20040506/testcases/kernel/syscalls/swapon/swapon02.c
+--- ltp-full-20040506.orig/testcases/kernel/syscalls/swapon/swapon02.c 2004-04-23 12:13:20.000000000 -0600
++++ ltp-full-20040506/testcases/kernel/syscalls/swapon/swapon02.c 2004-05-12 23:02:50.000000000 -0600
+@@ -85,9 +85,7 @@
+ #include <sys/swap.h>
+ #include <asm/page.h>
+ #include <asm/atomic.h>
+-#ifdef OLDER_DISTRO_RELEASE
+-#include <linux/swap.h>
+-#endif
++#define MAX_SWAPFILES 32
+ #include <fcntl.h>
+ #include <pwd.h>
+ #include <string.h>
+@@ -96,10 +94,6 @@
+ #include "test.h"
+ #include "usctest.h"
+
+-#ifndef OLDER_DISTRO_RELEASE
+-#define MAX_SWAPFILES 32
+-#endif
+-
+ static void setup();
+ static void cleanup();
+ static int setup01();