summaryrefslogtreecommitdiff
path: root/package/microcom
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/microcom
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/microcom')
-rw-r--r--package/microcom/Makefile.in3
-rw-r--r--package/microcom/microcom.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/microcom/Makefile.in b/package/microcom/Makefile.in
deleted file mode 100644
index b7653dc4d..000000000
--- a/package/microcom/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_MICROCOM)),y)
-TARGETS+=microcom
-endif
diff --git a/package/microcom/microcom.mk b/package/microcom/microcom.mk
index 4878ba9a3..0de393c83 100644
--- a/package/microcom/microcom.mk
+++ b/package/microcom/microcom.mk
@@ -57,3 +57,11 @@ microcom-dirclean:
microcom: uclibc $(TARGET_DIR)/usr/bin/microcom
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_MICROCOM)),y)
+TARGETS+=microcom
+endif