summaryrefslogtreecommitdiff
path: root/package/mpfr
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-11-28 16:54:30 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-11-28 16:54:30 +0000
commit3a65d24db5d239a2f9273cc4af87f292ef4414e9 (patch)
treee8eb174ece15b2761c41090c9b932b7f1f033403 /package/mpfr
parent784e010f2da834b6748e5521e2948880c0cff27e (diff)
- add "lib" prefix
Diffstat (limited to 'package/mpfr')
-rw-r--r--package/mpfr/Config.in10
-rw-r--r--package/mpfr/mpfr.mk14
2 files changed, 12 insertions, 12 deletions
diff --git a/package/mpfr/Config.in b/package/mpfr/Config.in
index 778e79e07..a7dabc959 100644
--- a/package/mpfr/Config.in
+++ b/package/mpfr/Config.in
@@ -1,8 +1,8 @@
-config BR2_PACKAGE_MPFR
+config BR2_PACKAGE_LIBMPFR
bool "mpfr"
default n
default y if BR2_INSTALL_FORTRAN
- select BR2_PACKAGE_GMP
+ select BR2_PACKAGE_LIBGMP
help
C library for multiple-precision floating-point computations
with exact rounding.
@@ -10,11 +10,11 @@ config BR2_PACKAGE_MPFR
http://www.mpfr.org/
-config BR2_PACKAGE_MPFR_HEADERS
+config BR2_PACKAGE_LIBMPFR_HEADERS
bool "mpfr headers for target"
default n
- depends on BR2_PACKAGE_MPFR
- select BR2_PACKAGE_GMP_HEADERS
+ depends on BR2_PACKAGE_LIBMPFR
+ select BR2_PACKAGE_LIBGMP_HEADERS
help
Install the mpfr headers for the target.
diff --git a/package/mpfr/mpfr.mk b/package/mpfr/mpfr.mk
index 096937248..dd940f291 100644
--- a/package/mpfr/mpfr.mk
+++ b/package/mpfr/mpfr.mk
@@ -22,7 +22,7 @@ $(DL_DIR)/$(MPFR_SOURCE):
$(WGET) -P $(DL_DIR) $(MPFR_SITE)/$(MPFR_SOURCE)
-mpfr-source: $(DL_DIR)/$(MPFR_SOURCE)
+libmpfr-source: $(DL_DIR)/$(MPFR_SOURCE)
$(MPFR_DIR)/.unpacked: $(DL_DIR)/$(MPFR_SOURCE)
$(MPFR_CAT) $(DL_DIR)/$(MPFR_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
@@ -81,20 +81,20 @@ $(STAGING_DIR)/lib/$(MPFR_BINARY): $(MPFR_DIR)/.libs/$(MPFR_BINARY)
$(TARGET_DIR)/lib/libmpfr.so.$(MPFR_LIBVERSION): $(STAGING_DIR)/lib/$(MPFR_BINARY)
cp -a $(STAGING_DIR)/lib/libmpfr.so* $(STAGING_DIR)/lib/libmpfr.a \
$(TARGET_DIR)/lib/
-ifeq ($(BR2_PACKAGE_MPFR_HEADERS),y)
+ifeq ($(BR2_PACKAGE_LIBMPFR_HEADERS),y)
cp -a $(STAGING_DIR)/include/mpfr.h $(STAGING_DIR)/include/mpf2mpfr.h \
$(TARGET_DIR)/usr/include/
endif
$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libmpfr.so* \
$(TARGET_DIR)/lib/libmpfr.a
-mpfr: uclibc $(TARGET_DIR)/lib/libmpfr.so.$(MPFR_LIBVERSION)
+libmpfr: uclibc libgmp $(TARGET_DIR)/lib/libmpfr.so.$(MPFR_LIBVERSION)
-mpfr-clean:
+libmpfr-clean:
rm -f $(TARGET_DIR)/lib/$(MPFR_BINARY)
-$(MAKE) -C $(MPFR_DIR) clean
-mpfr-dirclean:
+libmpfr-dirclean:
rm -rf $(MPFR_DIR)
#############################################################
@@ -102,6 +102,6 @@ mpfr-dirclean:
# Toplevel Makefile options
#
#############################################################
-ifeq ($(strip $(BR2_PACKAGE_MPFR)),y)
-TARGETS+=mpfr
+ifeq ($(strip $(BR2_PACKAGE_LIBMPFR)),y)
+TARGETS+=libmpfr
endif