summaryrefslogtreecommitdiff
path: root/package/multimedia/alsa-utils/alsa-utils.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-08-20 00:07:27 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-08-20 00:07:27 +0200
commit350b6c6e4b039ae0256e52cd06c6f6d769a1c2b1 (patch)
treeb54717b9ce9280a81abf7fadc097419e47a01d3c /package/multimedia/alsa-utils/alsa-utils.mk
parenta0c23b6d2b5ef8222a98d426cb42f6aa2e47b228 (diff)
alsa-utils: fix build for x86 on x86-64
alsa-utils included two ugly patches for ARM and AVR32 to fix build issues encountered with ncurses. In fact these build issues were caused by the fact that alsa-utils was using ncurses5-config of the host instead of the one installed in $(STAGING_DIR). Therefore, these two patches are removed, and we instead pass ac_cv_prog_ncurses5_config to the ./configure script. This commit solves bug #569, reported by Simon Pasch, who also contributed this fix. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/multimedia/alsa-utils/alsa-utils.mk')
-rw-r--r--package/multimedia/alsa-utils/alsa-utils.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/multimedia/alsa-utils/alsa-utils.mk b/package/multimedia/alsa-utils/alsa-utils.mk
index 06c6f138b..9f0b5d12d 100644
--- a/package/multimedia/alsa-utils/alsa-utils.mk
+++ b/package/multimedia/alsa-utils/alsa-utils.mk
@@ -17,7 +17,6 @@ $(DL_DIR)/$(ALSA_UTILS_SOURCE):
$(ALSA_UTILS_DIR)/.unpacked: $(DL_DIR)/$(ALSA_UTILS_SOURCE)
$(ALSA_UTILS_CAT) $(DL_DIR)/$(ALSA_UTILS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(ALSA_UTILS_DIR) package/multimedia/alsa-utils/ alsa-utils-$(ALSA_UTILS_VERSION)\*.patch
- toolchain/patch-kernel.sh $(ALSA_UTILS_DIR) package/multimedia/alsa-utils/ alsa-utils-$(ALSA_UTILS_VERSION)\*.patch.$(ARCH)
$(CONFIG_UPDATE) $(ALSA_UTILS_DIR)
touch $@
@@ -27,6 +26,7 @@ $(ALSA_UTILS_DIR)/.configured: $(ALSA_UTILS_DIR)/.unpacked
$(TARGET_CONFIGURE_ARGS) \
CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
+ ac_cv_prog_ncurses5_config=$(STAGING_DIR)/bin/ncurses5-config \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \