summaryrefslogtreecommitdiff
path: root/package/multimedia/festival/lexicons
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-11-15 21:33:07 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-11-15 21:33:07 +0000
commite7df5afeb9634a0d95499049efb5c4887069290d (patch)
tree307e4abcfc17552130058735e2d9dbd8e1f64784 /package/multimedia/festival/lexicons
parent4190cc1c4166160a2802efb1c090dd42ff2e7d6e (diff)
package/audio: rename audio category to multimedia
Prepare for the merge of audio and video packages. Many packages cannot properly be assigned to either audio or video, because they have support for both (libogg, mplayer, vlc). Signed-off-by: Markus Heidelberg <markus.heidelberg@web.de>
Diffstat (limited to 'package/multimedia/festival/lexicons')
-rw-r--r--package/multimedia/festival/lexicons/Config.in20
-rw-r--r--package/multimedia/festival/lexicons/festlex.mk46
2 files changed, 66 insertions, 0 deletions
diff --git a/package/multimedia/festival/lexicons/Config.in b/package/multimedia/festival/lexicons/Config.in
new file mode 100644
index 000000000..6d92883b3
--- /dev/null
+++ b/package/multimedia/festival/lexicons/Config.in
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_FESTLEX_CMU
+ bool "Carnegie Mellon University"
+ help
+ Lexicon for the festival text to speech system
+
+ http://festvox.org/packed/festival/latest
+
+config BR2_PACKAGE_FESTLEX_OALD
+ bool "Oxford Advanced Learners dictionary"
+ help
+ Lexicon for the festival text to speech system
+
+ http://festvox.org/packed/festival/latest
+
+config BR2_PACKAGE_FESTLEX_POS
+ bool "POSLEX"
+ help
+ Lexicon for the festival text to speech system
+
+ http://festvox.org/packed/festival/latest
diff --git a/package/multimedia/festival/lexicons/festlex.mk b/package/multimedia/festival/lexicons/festlex.mk
new file mode 100644
index 000000000..f5fdc9f76
--- /dev/null
+++ b/package/multimedia/festival/lexicons/festlex.mk
@@ -0,0 +1,46 @@
+#############################################################
+#
+# festival lexicons
+#
+#############################################################
+LEX1 = festlex_CMU.tar.gz
+LEX2 = festlex_OALD.tar.gz
+LEX3 = festlex_POSLEX.tar.gz
+FESTLEX_STATUS_DIR = $(BUILD_DIR)/festival_lexicons
+FESTLEX_INSTALL_DIR = $(TARGET_DIR)/usr/share
+
+$(FESTLEX_STATUS_DIR)/.downloaded:
+ mkdir -p $(FESTLEX_STATUS_DIR)
+ifeq ($(BR2_PACKAGE_FESTLEX_CMU),y)
+ $(Q)test -e $(DL_DIR)/$(LEX1) || $(WGET) -P $(DL_DIR) $(FESTIVAL_SITE)/$(LEX1)
+endif
+ifeq ($(BR2_PACKAGE_FESTLEX_OALD),y)
+ $(Q)test -e $(DL_DIR)/$(LEX2) || $(WGET) -P $(DL_DIR) $(FESTIVAL_SITE)/$(LEX2)
+endif
+ifeq ($(BR2_PACKAGE_FESTLEX_POS),y)
+ $(Q)test -e $(DL_DIR)/$(LEX3) || $(WGET) -P $(DL_DIR) $(FESTIVAL_SITE)/$(LEX3)
+endif
+ touch $@
+
+$(FESTLEX_STATUS_DIR)/.installed: $(FESTLEX_STATUS_DIR)/.downloaded
+ifeq ($(BR2_PACKAGE_FESTLEX_CMU),y)
+ tar -xvf $(DL_DIR)/$(LEX1) --directory $(FESTLEX_INSTALL_DIR)
+endif
+ifeq ($(BR2_PACKAGE_FESTLEX_OALD),y)
+ tar -xvf $(DL_DIR)/$(LEX2) --directory $(FESTLEX_INSTALL_DIR)
+endif
+ifeq ($(BR2_PACKAGE_FESTLEX_POS),y)
+ tar -xvf $(DL_DIR)/$(LEX3) --directory $(FESTLEX_INSTALL_DIR)
+endif
+ touch $@
+
+festlex: $(FESTLEX_STATUS_DIR)/.installed
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_FESTIVAL)),y)
+TARGETS+=festlex
+endif