summaryrefslogtreecommitdiff
path: root/package/multimedia/gst-plugins-good
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-06-04 20:11:42 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-06-24 00:49:18 +0200
commite607b0f9e3efaf96ffb2c3196f736c80232adc1b (patch)
tree0a77ab676240aa5a335e407e9e91b595e20b4e82 /package/multimedia/gst-plugins-good
parent07bae75635ebc0b2b3a2df8aca2f5022debacddb (diff)
gstreamer: add xorg support
GStreamer requires xorg support in order for the ximagesink and xvimagesink plugins to be available. Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/gst-plugins-good')
-rw-r--r--package/multimedia/gst-plugins-good/gst-plugins-good.mk16
1 files changed, 13 insertions, 3 deletions
diff --git a/package/multimedia/gst-plugins-good/gst-plugins-good.mk b/package/multimedia/gst-plugins-good/gst-plugins-good.mk
index 4e6b73e5d..ebd463b0e 100644
--- a/package/multimedia/gst-plugins-good/gst-plugins-good.mk
+++ b/package/multimedia/gst-plugins-good/gst-plugins-good.mk
@@ -14,9 +14,6 @@ GST_PLUGINS_GOOD_CONF_OPT = \
--disable-sunaudio \
--disable-osx_audio \
--disable-osx_video \
- --disable-x \
- --disable-xshm \
- --disable-xvideo \
--disable-aalib \
--disable-aalibtest \
--disable-esd \
@@ -25,6 +22,19 @@ GST_PLUGINS_GOOD_CONF_OPT = \
GST_PLUGINS_GOOD_DEPENDENCIES = gstreamer gst-plugins-base
+ifeq ($(BR2_PACKAGE_XORG7),y)
+GST_PLUGINS_GOOD_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXv
+GST_PLUGINS_GOOD_CONF_OPT += \
+ --enable-x \
+ --enable-xshm \
+ --enable-xvideo
+else
+GST_PLUGINS_GOOD_CONF_OPT += \
+ --disable-x \
+ --disable-xshm \
+ --disable-xvideo
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_JPEG),y)
GST_PLUGINS_GOOD_CONF_OPT += --enable-jpeg
GST_PLUGINS_GOOD_DEPENDENCIES += jpeg