summaryrefslogtreecommitdiff
path: root/package/multimedia/gstreamer
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-08 17:48:31 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-08 17:48:31 +0000
commit39048383696dc8e53a48b77249ccf1ea5080be29 (patch)
treea096d5dadba390a23ac8fcb0c540fbcfa7c71606 /package/multimedia/gstreamer
parentcd900a0d595fc266d984fce8339445be37a4e29e (diff)
gstreamer: add new multimedia package gstreamer
gstreamer is powerful framework for streaming media.
Diffstat (limited to 'package/multimedia/gstreamer')
-rw-r--r--package/multimedia/gstreamer/Config.in9
-rw-r--r--package/multimedia/gstreamer/gstreamer-0.10.21-build_fix_missing_gtkdoc.patch43
-rw-r--r--package/multimedia/gstreamer/gstreamer.mk33
3 files changed, 85 insertions, 0 deletions
diff --git a/package/multimedia/gstreamer/Config.in b/package/multimedia/gstreamer/Config.in
new file mode 100644
index 000000000..37e1427cf
--- /dev/null
+++ b/package/multimedia/gstreamer/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_GSTREAMER
+ bool "gstreamer"
+ select BR2_PACKAGE_LIBGLIB2
+ select BR2_PACKAGE_LIBXML2
+ select BR2_PACKAGE_PKGCONFIG
+ help
+ GStreamer is an open source multimedia framework.
+
+ http://gstreamer.freedesktop.org/
diff --git a/package/multimedia/gstreamer/gstreamer-0.10.21-build_fix_missing_gtkdoc.patch b/package/multimedia/gstreamer/gstreamer-0.10.21-build_fix_missing_gtkdoc.patch
new file mode 100644
index 000000000..246b3dbd0
--- /dev/null
+++ b/package/multimedia/gstreamer/gstreamer-0.10.21-build_fix_missing_gtkdoc.patch
@@ -0,0 +1,43 @@
+Submitted By: Ken Moffat <ken at linuxfromscratch dot org>
+Date: 2008-10-15
+Initial Package Version: 0.10.21
+Upstream Status: Not yet known, just raised as gnome bug 556348.
+Origin: Self
+Description: Allows 'make install' to succeed if gtkdoc-rebase is not present.
+
+diff -Naur gstreamer-0.10.21.orig/common/gtk-doc.mak gstreamer-0.10.21/common/gtk-doc.mak
+--- gstreamer-0.10.21.orig/common/gtk-doc.mak 2008-09-10 10:13:16.000000000 +0100
++++ gstreamer-0.10.21/common/gtk-doc.mak 2008-10-15 18:12:18.000000000 +0100
+@@ -201,7 +201,7 @@
+ $(DESTDIR)$(TARGET_DIR)/$(DOC_MODULE)-@GST_MAJORMINOR@.devhelp2; \
+ fi; \
+ which gtkdoc-rebase >/dev/null && \
+- gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
++ gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) || true ; \
+ fi)
+ uninstall-local:
+ (installfiles=`echo ./html/*.html`; \
+diff -Naur gstreamer-0.10.21.orig/docs/gst/Makefile.in gstreamer-0.10.21/docs/gst/Makefile.in
+--- gstreamer-0.10.21.orig/docs/gst/Makefile.in 2008-10-02 22:54:18.000000000 +0100
++++ gstreamer-0.10.21/docs/gst/Makefile.in 2008-10-15 18:12:45.000000000 +0100
+@@ -809,7 +809,7 @@
+ $(DESTDIR)$(TARGET_DIR)/$(DOC_MODULE)-@GST_MAJORMINOR@.devhelp2; \
+ fi; \
+ which gtkdoc-rebase >/dev/null && \
+- gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
++ gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) || true ; \
+ fi)
+ uninstall-local:
+ (installfiles=`echo ./html/*.html`; \
+diff -Naur gstreamer-0.10.21.orig/docs/libs/Makefile.in gstreamer-0.10.21/docs/libs/Makefile.in
+--- gstreamer-0.10.21.orig/docs/libs/Makefile.in 2008-10-02 22:54:18.000000000 +0100
++++ gstreamer-0.10.21/docs/libs/Makefile.in 2008-10-15 18:12:18.000000000 +0100
+@@ -811,7 +811,7 @@
+ $(DESTDIR)$(TARGET_DIR)/$(DOC_MODULE)-@GST_MAJORMINOR@.devhelp2; \
+ fi; \
+ which gtkdoc-rebase >/dev/null && \
+- gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
++ gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) || true ; \
+ fi)
+ uninstall-local:
+ (installfiles=`echo ./html/*.html`; \
diff --git a/package/multimedia/gstreamer/gstreamer.mk b/package/multimedia/gstreamer/gstreamer.mk
new file mode 100644
index 000000000..ba66b83ba
--- /dev/null
+++ b/package/multimedia/gstreamer/gstreamer.mk
@@ -0,0 +1,33 @@
+#############################################################
+#
+# gstreamer
+#
+#############################################################
+GSTREAMER_VERSION = 0.10.21
+GSTREAMER_SOURCE = gstreamer-$(GSTREAMER_VERSION).tar.bz2
+GSTREAMER_SITE = http://gstreamer.freedesktop.org/src/gstreamer
+GSTREAMER_INSTALL_STAGING = YES
+
+# Checking if unaligned memory access works correctly cannot be done when cross
+# compiling. For the following architectures there is no information available
+# in the configure script.
+ifeq ($(BR2_avr32),y)
+GSTREAMER_CONF_ENV = as_cv_unaligned_access=no
+endif
+ifeq ($(BR2_nios2),y)
+GSTREAMER_CONF_ENV = as_cv_unaligned_access=no
+endif
+ifeq ($(BR2_s390),y)
+GSTREAMER_CONF_ENV = as_cv_unaligned_access=yes
+endif
+
+GSTREAMER_CONF_OPT = \
+ $(DISABLE_NLS) \
+ $(DISABLE_LARGEFILE) \
+ --disable-examples \
+ --disable-tests \
+ --disable-failing-tests
+
+GSTREAMER_DEPENDENCIES = libglib2 libxml2 pkgconfig
+
+$(eval $(call AUTOTARGETS,package/multimedia,gstreamer))