summaryrefslogtreecommitdiff
path: root/package/multimedia
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-29 21:57:42 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-29 23:09:58 +0200
commit0849e8193ef429f29945b8c2a54eafc8635e0969 (patch)
tree87934d420647a042d53c0332e15d4d02404b8010 /package/multimedia
parente055aea216cff4d12cf55eab2e35ca1459edaa91 (diff)
package: remove useless arguments from GENTARGETS
Thanks to the pkgparentdir and pkgname functions, we can rewrite the GENTARGETS macro in a way that avoids the need for each package to repeat its name and the directory in which it is present. [Peter: pkgdir->pkgparentdir] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia')
-rw-r--r--package/multimedia/gst-dsp/gst-dsp.mk2
-rw-r--r--package/multimedia/gst-omapfb/gst-omapfb.mk2
-rw-r--r--package/multimedia/live555/live555.mk2
-rw-r--r--package/multimedia/mplayer/mplayer.mk2
-rw-r--r--package/multimedia/python-mad/python-mad.mk2
-rw-r--r--package/multimedia/tidsp-binaries/tidsp-binaries.mk2
6 files changed, 6 insertions, 6 deletions
diff --git a/package/multimedia/gst-dsp/gst-dsp.mk b/package/multimedia/gst-dsp/gst-dsp.mk
index f55f5109a..17eb18966 100644
--- a/package/multimedia/gst-dsp/gst-dsp.mk
+++ b/package/multimedia/gst-dsp/gst-dsp.mk
@@ -16,4 +16,4 @@ endef
GST_DSP_DEPENDENCIES = gstreamer tidsp-binaries
-$(eval $(call GENTARGETS,package/multimedia,gst-dsp))
+$(eval $(call GENTARGETS))
diff --git a/package/multimedia/gst-omapfb/gst-omapfb.mk b/package/multimedia/gst-omapfb/gst-omapfb.mk
index 726ef83fe..f3956bc14 100644
--- a/package/multimedia/gst-omapfb/gst-omapfb.mk
+++ b/package/multimedia/gst-omapfb/gst-omapfb.mk
@@ -16,4 +16,4 @@ endef
GST_OMAPFB_DEPENDENCIES = gstreamer
-$(eval $(call GENTARGETS,package/multimedia,gst-omapfb))
+$(eval $(call GENTARGETS))
diff --git a/package/multimedia/live555/live555.mk b/package/multimedia/live555/live555.mk
index 45a037582..0051ea068 100644
--- a/package/multimedia/live555/live555.mk
+++ b/package/multimedia/live555/live555.mk
@@ -45,4 +45,4 @@ define LIVE555_UNINSTALL_TARGET_CMDS
done
endef
-$(eval $(call GENTARGETS,package/multimedia,live555))
+$(eval $(call GENTARGETS))
diff --git a/package/multimedia/mplayer/mplayer.mk b/package/multimedia/mplayer/mplayer.mk
index f735464d1..4c0344019 100644
--- a/package/multimedia/mplayer/mplayer.mk
+++ b/package/multimedia/mplayer/mplayer.mk
@@ -145,4 +145,4 @@ define MPLAYER_CLEAN_CMDS
$(MAKE) -C $(@D) clean
endef
-$(eval $(call GENTARGETS,package/multimedia,mplayer))
+$(eval $(call GENTARGETS))
diff --git a/package/multimedia/python-mad/python-mad.mk b/package/multimedia/python-mad/python-mad.mk
index 52d13a650..7d898eddc 100644
--- a/package/multimedia/python-mad/python-mad.mk
+++ b/package/multimedia/python-mad/python-mad.mk
@@ -38,4 +38,4 @@ define PYTHON_MAD_INSTALL_TARGET_CMDS
(cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
endef
-$(eval $(call GENTARGETS,package,python-mad))
+$(eval $(call GENTARGETS))
diff --git a/package/multimedia/tidsp-binaries/tidsp-binaries.mk b/package/multimedia/tidsp-binaries/tidsp-binaries.mk
index 102791fab..0b64fb848 100644
--- a/package/multimedia/tidsp-binaries/tidsp-binaries.mk
+++ b/package/multimedia/tidsp-binaries/tidsp-binaries.mk
@@ -10,4 +10,4 @@ define TIDSP_BINARIES_UNINSTALL_TARGET_CMDS
$(RM) -r $(TARGET_DIR)/lib/dsp
endef
-$(eval $(call GENTARGETS,package/multimedia,tidsp-binaries))
+$(eval $(call GENTARGETS))