summaryrefslogtreecommitdiff
path: root/package/multimedia
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-08 17:45:59 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-08 17:45:59 +0000
commitcd900a0d595fc266d984fce8339445be37a4e29e (patch)
tree8c63142987c3ed84d090bcb829f8ce5f733cbb33 /package/multimedia
parent7139678f781225bbd2e147a1bcbcf7e4d6d7499e (diff)
libtheora: add new multimedia package libtheora
libtheora is a library used by gstreamer when streaming Ogg multimedia.
Diffstat (limited to 'package/multimedia')
-rw-r--r--package/multimedia/Config.in1
-rw-r--r--package/multimedia/libtheora/Config.in10
-rw-r--r--package/multimedia/libtheora/libtheora.mk19
3 files changed, 30 insertions, 0 deletions
diff --git a/package/multimedia/Config.in b/package/multimedia/Config.in
index 4568a51bb..4c74f7ed6 100644
--- a/package/multimedia/Config.in
+++ b/package/multimedia/Config.in
@@ -7,6 +7,7 @@ source "package/multimedia/libid3tag/Config.in"
source "package/multimedia/libmad/Config.in"
source "package/multimedia/libogg/Config.in"
source "package/multimedia/libsndfile/Config.in"
+source "package/multimedia/libtheora/Config.in"
source "package/multimedia/libvorbis/Config.in"
source "package/multimedia/madplay/Config.in"
source "package/multimedia/mpg123/Config.in"
diff --git a/package/multimedia/libtheora/Config.in b/package/multimedia/libtheora/Config.in
new file mode 100644
index 000000000..97a70870f
--- /dev/null
+++ b/package/multimedia/libtheora/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LIBTHEORA
+ bool "libtheora"
+ select BR2_PACKAGE_LIBOGG
+ select BR2_PACKAGE_LIBVORBIS
+ select BR2_PACKAGE_PKGCONFIG
+ help
+ A library for the free and open video compression format "Theora"
+ from the Xiph.org Foundation.
+
+ http://www.theora.org/
diff --git a/package/multimedia/libtheora/libtheora.mk b/package/multimedia/libtheora/libtheora.mk
new file mode 100644
index 000000000..1d311d204
--- /dev/null
+++ b/package/multimedia/libtheora/libtheora.mk
@@ -0,0 +1,19 @@
+#############################################################
+#
+# libtheora
+#
+#############################################################
+LIBTHEORA_VERSION = 1.0
+LIBTHEORA_SOURCE = libtheora-$(LIBTHEORA_VERSION).tar.bz2
+LIBTHEORA_SITE = http://downloads.xiph.org/releases/theora
+LIBTHEORA_INSTALL_STAGING = YES
+
+LIBTHEORA_CONF_OPT = \
+ --disable-oggtest \
+ --disable-vorbistest \
+ --disable-sdltest \
+ --disable-examples
+
+LIBTHEORA_DEPENDENCIES = libogg libvorbis pkgconfig
+
+$(eval $(call AUTOTARGETS,package/multimedia,libtheora))