summaryrefslogtreecommitdiff
path: root/package/multimedia
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
commit77754571b2f327636ce0072cfabc9ce0c9a6ad86 (patch)
tree56fc2d3552653caaa20ee7577b1a04375f80bf28 /package/multimedia
parent344d59d788d697f4f6704dd920cad615318e47be (diff)
pkgconfig: add pkgconfig package for target
The host versions shouldn't be visible in Kconfig, so remove the reference to BR2_PACKAGE_PKGCONFIG everywhere and prefix the host targets with host-. At the same time add pkgconfig for the target (E.G. for development) and let BR2_PACKAGE_PKGCONFIG control that package. Notice: all defconfigs in the tree have been updated, but make sure to disable the pkgconfig package (unless you want it) if you use an external config, otherwise you'll end up with pkgconfig and glib2 in the target.
Diffstat (limited to 'package/multimedia')
-rw-r--r--package/multimedia/gstreamer/Config.in1
-rw-r--r--package/multimedia/gstreamer/gstreamer.mk2
-rw-r--r--package/multimedia/libmpd/Config.in1
-rw-r--r--package/multimedia/libogg/Config.in1
-rw-r--r--package/multimedia/libogg/libogg.mk2
-rw-r--r--package/multimedia/libtheora/Config.in1
-rw-r--r--package/multimedia/libtheora/libtheora.mk2
-rw-r--r--package/multimedia/libvorbis/Config.in1
-rw-r--r--package/multimedia/libvorbis/libvorbis.mk4
9 files changed, 5 insertions, 10 deletions
diff --git a/package/multimedia/gstreamer/Config.in b/package/multimedia/gstreamer/Config.in
index 37e1427cf..213d65010 100644
--- a/package/multimedia/gstreamer/Config.in
+++ b/package/multimedia/gstreamer/Config.in
@@ -2,7 +2,6 @@ config BR2_PACKAGE_GSTREAMER
bool "gstreamer"
select BR2_PACKAGE_LIBGLIB2
select BR2_PACKAGE_LIBXML2
- select BR2_PACKAGE_PKGCONFIG
help
GStreamer is an open source multimedia framework.
diff --git a/package/multimedia/gstreamer/gstreamer.mk b/package/multimedia/gstreamer/gstreamer.mk
index fb9a3b910..4c17d4e7e 100644
--- a/package/multimedia/gstreamer/gstreamer.mk
+++ b/package/multimedia/gstreamer/gstreamer.mk
@@ -23,6 +23,6 @@ GSTREAMER_CONF_OPT = \
--disable-tests \
--disable-failing-tests
-GSTREAMER_DEPENDENCIES = libglib2 libxml2 pkgconfig
+GSTREAMER_DEPENDENCIES = libglib2 libxml2 host-pkgconfig
$(eval $(call AUTOTARGETS,package/multimedia,gstreamer))
diff --git a/package/multimedia/libmpd/Config.in b/package/multimedia/libmpd/Config.in
index 72630ad27..c79203c99 100644
--- a/package/multimedia/libmpd/Config.in
+++ b/package/multimedia/libmpd/Config.in
@@ -4,7 +4,6 @@ config BR2_PACKAGE_LIBMPD
select BR2_PACKAGE_GETTEXT
select BR2_PACKAGE_LIBINTL
select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
- select BR2_PACKAGE_PKGCONFIG
help
High-level client library for accessing Music Player Daemon.
LibMpd is a library that provides high-level, callback-based
diff --git a/package/multimedia/libogg/Config.in b/package/multimedia/libogg/Config.in
index bbaf08797..effe74fb3 100644
--- a/package/multimedia/libogg/Config.in
+++ b/package/multimedia/libogg/Config.in
@@ -1,6 +1,5 @@
config BR2_PACKAGE_LIBOGG
bool "libogg"
- select BR2_PACKAGE_PKGCONFIG
help
Ogg is the name of Xiph.org's container format for audio,
video, and metadata
diff --git a/package/multimedia/libogg/libogg.mk b/package/multimedia/libogg/libogg.mk
index 8ea08353b..c76c9323a 100644
--- a/package/multimedia/libogg/libogg.mk
+++ b/package/multimedia/libogg/libogg.mk
@@ -10,6 +10,6 @@ LIBOGG_AUTORECONF = NO
LIBOGG_INSTALL_STAGING = YES
LIBOGG_INSTALL_TARGET = YES
-LIBOGG_DEPENDENCIES = uclibc pkgconfig
+LIBOGG_DEPENDENCIES = uclibc host-pkgconfig
$(eval $(call AUTOTARGETS,package/multimedia,libogg))
diff --git a/package/multimedia/libtheora/Config.in b/package/multimedia/libtheora/Config.in
index 97a70870f..bf20a5037 100644
--- a/package/multimedia/libtheora/Config.in
+++ b/package/multimedia/libtheora/Config.in
@@ -2,7 +2,6 @@ config BR2_PACKAGE_LIBTHEORA
bool "libtheora"
select BR2_PACKAGE_LIBOGG
select BR2_PACKAGE_LIBVORBIS
- select BR2_PACKAGE_PKGCONFIG
help
A library for the free and open video compression format "Theora"
from the Xiph.org Foundation.
diff --git a/package/multimedia/libtheora/libtheora.mk b/package/multimedia/libtheora/libtheora.mk
index 1d311d204..d6a9b2a9d 100644
--- a/package/multimedia/libtheora/libtheora.mk
+++ b/package/multimedia/libtheora/libtheora.mk
@@ -14,6 +14,6 @@ LIBTHEORA_CONF_OPT = \
--disable-sdltest \
--disable-examples
-LIBTHEORA_DEPENDENCIES = libogg libvorbis pkgconfig
+LIBTHEORA_DEPENDENCIES = libogg libvorbis host-pkgconfig
$(eval $(call AUTOTARGETS,package/multimedia,libtheora))
diff --git a/package/multimedia/libvorbis/Config.in b/package/multimedia/libvorbis/Config.in
index 929713e76..28a6a2ea0 100644
--- a/package/multimedia/libvorbis/Config.in
+++ b/package/multimedia/libvorbis/Config.in
@@ -1,7 +1,6 @@
config BR2_PACKAGE_LIBVORBIS
bool "libvorbis"
select BR2_PACKAGE_LIBOGG
- select BR2_PACKAGE_PKGCONFIG
help
Library for the Vorbis open source audio decoder
Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
diff --git a/package/multimedia/libvorbis/libvorbis.mk b/package/multimedia/libvorbis/libvorbis.mk
index 74a9b086f..bda141efa 100644
--- a/package/multimedia/libvorbis/libvorbis.mk
+++ b/package/multimedia/libvorbis/libvorbis.mk
@@ -13,7 +13,7 @@ LIBVORBIS_INSTALL_TARGET = YES
LIBVORBIS_CONF_OPT = --disable-oggtest
-LIBVORBIS_DEPENDENCIES = uclibc pkgconfig libogg
+LIBVORBIS_DEPENDENCIES = uclibc host-pkgconfig libogg
$(eval $(call AUTOTARGETS,package/multimedia,libvorbis))
@@ -76,7 +76,7 @@ $(TARGET_DIR)/usr/lib/tremor.a: $(TARGET_DIR)/usr/lib/tremor.so
cp -dpf $(TREMOR_DIR)/lib/tremor.a $(TARGET_DIR)/usr/lib/
touch $@
-tremor: uclibc pkgconfig host-autoconf host-automake libogg $(TARGET_DIR)/usr/lib/tremor.so
+tremor: uclibc host-pkgconfig host-autoconf host-automake libogg $(TARGET_DIR)/usr/lib/tremor.so
tremor-source: $(DL_DIR)/$(TREMOR_SOURCE)