summaryrefslogtreecommitdiff
path: root/package/neon/neon.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-12-20 23:49:45 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-12-20 23:49:45 +0100
commit2f3c46561e585ba698e73a91bbff03b2e3be411c (patch)
tree53f1475ed097e2d3ea72dcca8ba4b8198f810343 /package/neon/neon.mk
parent14aa5ee54f33d05a0bd01f21635e095ba07f83ec (diff)
neon: add optional ssl support
Signed-off-by: Nigel Kukard <nkukard@lbsd.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/neon/neon.mk')
-rw-r--r--package/neon/neon.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index 1f26a0c96..ed5f99968 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -22,6 +22,12 @@ NEON_DEPENDENCIES+=zlib
else
NEON_CONF_OPT+=--without-zlib
endif
+ifeq ($(BR2_PACKAGE_NEON_SSL),y)
+NEON_CONF_OPT+=--with-ssl
+NEON_DEPENDENCIES+=openssl
+else
+NEON_CONF_OPT+=--without-ssl
+endif
ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
NEON_CONF_OPT+=--with-libxml2=no