summaryrefslogtreecommitdiff
path: root/package/neon/neon.mk
diff options
context:
space:
mode:
authorNigel Kukard <nkukard@lbsd.net>2008-12-31 18:22:43 +0000
committerNigel Kukard <nkukard@lbsd.net>2008-12-31 18:22:43 +0000
commitcc6562ff839502a65a3b202ffe7fa3c67bae0856 (patch)
tree99d671023759162e413ef9154759d029e601245b /package/neon/neon.mk
parenta36ca7a8c5ebc54fee2672b8e0c378c03089daa7 (diff)
* Refined building of neon options
- Added support to build with or without zlib support
Diffstat (limited to 'package/neon/neon.mk')
-rw-r--r--package/neon/neon.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index e92e134b6..61cf7527e 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -16,6 +16,12 @@ NEON_CONF_OPT+=--with-libxml2=yes
NEON_CONF_OPT+=--with-expat=no
NEON_DEPENDENCIES+=libxml2
endif
+ifeq ($(BR2_PACKAGE_NEON_ZLIB),y)
+NEON_CONF_OPT+=--with-zlib=$(STAGING_DIR)
+NEON_DEPENDENCIES+=zlib
+else
+NEON_CONF_OPT+=--without-zlib
+endif
ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
NEON_CONF_OPT+=--with-libxml2=no